### List of related manuals

<table>
<thead>
<tr>
<th>Drive firmware manuals and guides</th>
<th>Code (English)</th>
</tr>
</thead>
<tbody>
<tr>
<td>ACS880 primary control program firmware manual</td>
<td>3AUA0000085967</td>
</tr>
<tr>
<td>ACS580 standard control program firmware manual</td>
<td>3AXD50000016097</td>
</tr>
<tr>
<td><strong>Option manuals and guides</strong></td>
<td></td>
</tr>
<tr>
<td>FENA-01/-11/-21 Ethernet adapter module user’s manual</td>
<td>3AUA0000093568</td>
</tr>
<tr>
<td>FSO-11 safety functions module user’s manual</td>
<td>3AUA0000097054</td>
</tr>
<tr>
<td>FSO-12 safety functions module user’s manual</td>
<td>3AXD50000015612</td>
</tr>
<tr>
<td>FPBA-01 PROFIBUS DP adapter module user’s manual</td>
<td>3AFE68573271</td>
</tr>
<tr>
<td><strong>Tool manuals</strong></td>
<td></td>
</tr>
<tr>
<td>Drive composer start-up and maintenance PC tool user’s manual</td>
<td>3AUA0000094606</td>
</tr>
<tr>
<td>Ethernet tool network for ACS880 drives application guide</td>
<td>3AUA0000125635</td>
</tr>
<tr>
<td>Adaptive programming application guide</td>
<td>3AXD50000028574</td>
</tr>
</tbody>
</table>

All manuals are available in PDF format on the Internet. See section Document library on the Internet on the inside of the back cover.
User’s manual

Start-up and maintenance PC tool
Drive composer

Table of contents
# Table of contents

## 1. Introduction to the manual
- Contents of this chapter ........................................... 13
- Applicability .......................................................... 13
- Target audience ....................................................... 13
- Purpose of the manual .............................................. 13
- Contents .................................................................. 14
- Terms and abbreviations used in this manual ................. 15

## 2. Overview of Drive composer
- Contents of this chapter ........................................... 17
- Drive composer ......................................................... 17
- Compatibility .......................................................... 17
- Highlights .............................................................. 18
- Features ................................................................ 19
- Hardware and software requirements ............................ 20
  - Drive composer hardware ........................................ 20
  - Computer hardware ............................................... 20
  - Software ............................................................ 20

## 3. Installation and uninstallation of Drive composer
- Contents of this chapter ........................................... 21
- Determining the current Drive composer version ............ 21
- Installing Drive composer with the installer ................. 22
- Uninstalling Drive composer with the installer .............. 25
- Registration ........................................................... 26
  - Online registration ............................................... 26
  - Offline registration .............................................. 26

## 4. Connections
- Contents of this chapter ........................................... 27
- Assistant control panel drivers .................................... 27
- Connecting to a drive with an Assistant control panel for the first time ..................................................... 28
- Changing the language settings ................................... 30
- Connecting to a drive via an Ethernet network .............. 32
  - Ethernet network connection .................................. 32
    - Creating an Ethernet network connection with Drive composer (pro) ............................................... 32
      - Configuring the TCP/IP address with Windows XP ................................................................. 33
      - Configuring the TCP/IP address with Windows 7 ................................................................. 36
    - Configuring the TCP/IP address with Windows 7 ........................................................................ 36
- Connecting network drives (pro) ................................ 41
  - Panel bus network connection .................................. 41
  - Creating a panel bus with Drive composer (pro) ........ 41
  - Connecting to the panel bus with Drive composer (pro) ............................................................. 42
- Connection sharing (pro) ............................................ 43
5. Main user interface components

Contents of this chapter ......................................................... 45
Overview ................................................................. 45
Title bar ................................................................. 46
  System menu ......................................................... 48
Menu bar ................................................................. 49
  File menu ............................................................ 49
  Edit menu ............................................................ 51
  View menu ........................................................... 52
  Tools menu (pro) ..................................................... 53
  Help menu ............................................................ 54
Drive control panel ......................................................... 55
  Drive list panel ....................................................... 56
  Using the drive control panel for starting the drive .......... 57
Working area ............................................................. 58

6. Parameter window

Contents of this chapter ......................................................... 59
Parameter window ............................................................ 59
Navigating parameters and groups ......................................... 62
Pointer parameters .......................................................... 65
  Setting fieldbus data in/out parameters .................................. 67
Binary parameters ........................................................... 69
Search for groups and parameters ......................................... 70
Custom parameter window .................................................... 71
Adding parameters to a custom parameter window .................... 72
Working with offline files .................................................... 75
  Types of offline files .................................................. 75
  Saving parameters to a parameter file .................................. 75
  Opening a parameter file (entry) ...................................... 76
  Opening an offline file containing parameter values (pro) ....... 76
  Downloading parameter values to a drive .......................... 76
  Comparing drive data (pro) .......................................... 77

7. Monitor window

Contents of this chapter ......................................................... 79
Monitor window ............................................................. 79
  Resizing the monitor window ........................................... 80
Adding parameters/signals for monitoring .................................. 81
  Monitor window components ............................................ 83
Configuration and control settings ......................................... 84
Monitor controls ............................................................ 85
Active signal ............................................................... 86
Zooming ..................................................................... 87
Panning ...................................................................... 87
Legend area functions ........................................................ 88
Graph area functions ........................................................ 88
  Double cursor tool .................................................... 89
8. Workspace handling
Contents of this chapter .......................................................... 91
Overview ................................................................................. 91
Creating a workspace and using it as a default workspace .......... 92

9. Event logger
Contents of this chapter .......................................................... 95
Event logger view ...................................................................... 95
Fault data logger ..................................................................... 97

10. Diagnostics
Contents of this chapter .......................................................... 99
Support package ....................................................................... 99
Creating a support package ..................................................... 99
Opening a support package (pro) ............................................. 100
Drive application programming license .................................. 101
System info .............................................................................. 101
Data logger (pro) ................................................................. 102
Data logger settings ............................................................... 104
Data logger commands ........................................................... 104
Data logger content configuration ........................................... 104
Data logger trigger configuration ............................................. 106
Adding a trigger ...................................................................... 107
Using the level triggers ............................................................ 107
Using bit mask trigger .............................................................. 107
Uploading triggered or stopped data logger data ..................... 108
Amplitude logger (pro) ............................................................. 109
Macro (pro) ........................................................................... 110
Macro commands ................................................................. 111
Macro language ..................................................................... 111
Simple example ..................................................................... 111
Additional macro commands .................................................. 111
Target .................................................................................... 111
Target name ........................................................................... 112
Parwrite ............................................................................... 112
Parread ................................................................................ 112
Wait ..................................................................................... 112
Endmacro ............................................................................. 112
Gotomacro .......................................................................... 113
Message box ........................................................................ 113

11. Control diagrams (pro)
Contents this chapter ............................................................ 115
Control diagrams .................................................................. 115

12. FSO configuration (pro)
Contents of this chapter ........................................................ 119
Configuring FSO-11 and FSO-12 ............................................. 119
Hardware connection ............................................................ 119
13. Other functions

Contents of this chapter ................................................................. 131
Creating a backup of a drive .......................................................... 131
Restoring a drive ................................................................. 132
Using the Drive parameter conversion tool (pro) .......................... 133
Using the PSL2 data logger (pro) .................................................. 136
    Uploading PSL2 data logger files .............................................. 136
Adaptive programming ............................................................. 137

Further information

Product and service inquiries ....................................................... 139
Product training ................................................................. 139
Providing feedback on ABB Drives manuals ................................. 139
Document library on the Internet .................................................. 139
List of figures

About the product dialog box ........................................... 21
Run as administrator ....................................................... 22
Drive composer setup wizard window .................................. 22
Destination folder window ................................................ 23
Installation .................................................................. 23
Installation Complete window ........................................... 24
Removing Drive composer .................................................. 25
Confirming the removal of Drive composer ............................ 25
Online activation ............................................................. 26
Import licence file ................................................................ 26
USB connection between Assistant control panel and PC ........ 28
Connect/Demo button ......................................................... 28
Parameters loaded ............................................................. 29
View-Settings .................................................................. 30
Language settings ............................................................. 30
IP settings of the drive with Drive composer ......................... 32
Naming a drive with Drive composer .................................... 32
Network Connections window ............................................. 33
Local Area Connection Status dialog box ................................. 34
Local Area Connection Properties dialog box ......................... 34
Use the following IP address option selected ......................... 35
Win 7 Control Panel .......................................................... 36
Network status and tasks ..................................................... 36
Local Area Connection ....................................................... 37
Local Area Connection Status dialog box ................................. 37
Local Area Connection Properties dialog box ......................... 38
Selecting the IP address and subnet mask .............................. 39
Pinging drives ................................................................. 40
Creating a panel bus .......................................................... 41
Panel port settings with Drive composer ................................ 41
Naming a drive with Drive composer .................................... 42
Connection sharing ........................................................... 43
Overview of the user interface ............................................. 46
Title bar ........................................................................ 46
Save workspace on exit function ........................................... 47
System menu .................................................................. 48
File menu ..................................................................... 49
Custom parameter set ......................................................... 49
Open command ................................................................ 50
Edit menu .................................................................... 51
View menu .................................................................... 52
A-letter icons for changing the font size ................................. 52
Tools menu .................................................................... 53
Help menu ..................................................................... 54
Drive control panel ............................................................ 55
Drive list panel in Drive composer pro ................................. 56
Stopped drive ................................................................. 56
Running drive .............................................................. 56
Faulty drive ................................................................. 56
Drive with an alarm ......................................................... 56
Drive with a broken connection ....................................... 57
Tabbed user interface ....................................................... 58
Floating windows ......................................................... 58
Parameter window ......................................................... 61
Bit names for a parameter .............................................. 63
Parameters with a yellow background ............................... 64
Constant value for a pointer parameter ............................. 65
Inverting a bit pointer value ............................................ 66
Inverted bit pointer value with the minus sign ........................ 66
Selecting the data type ..................................................... 67
Selecting the format ....................................................... 68
Formats shown inside brackets in the parameter window ......... 68
Binary parameter editor ................................................. 69
Search example ............................................................. 70
Download to device button ............................................. 71
Change drive button ....................................................... 71
Custom parameter set ..................................................... 72
Name of window ........................................................... 72
Add parameter button ..................................................... 72
Add minimum and maximum values .................................. 73
Save parameter to file icon ............................................. 73
Download to device ....................................................... 74
Save parameters to file icon ............................................ 75
Saving the dcparamsbak file ............................................ 75
Opening parameters from Parameter file ........................... 76
Opening parameters from Parameter file ........................... 76
Changing drive ............................................................ 76
Download to device icon .................................................. 77
Comparing drive parameters ............................................ 77
Result of a comparison ................................................... 78
Monitor window ............................................................ 80
Send to monitor command .............................................. 81
Icons on the configuration and control area in the monitor window ....................................................... 81
Drive list ........................................................................ 82
Changing the pen color and style in the legend area .......... 82
Active signal area .......................................................... 86
Measuring points for the active signal ............................... 86
Search functionality ........................................................ 87
Zoom tool ........................................................................ 87
Legend area functions ..................................................... 88
Double cursor tool .......................................................... 89
Custom parameter set ..................................................... 92
Save workspace command ............................................... 92
Name for your own workspace ......................................... 93
Open workspace command ............................................. 94
Event logger view ........................................................... 96
Fault data icon ................................................................. 97
Fault data logger in the monitor window .............................. 97
Support package button .................................................... 99
Available modules of Support package ................................ 100
System info command ....................................................... 101
System info ................................................................. 101
Data logger configuration .................................................. 102
Data logger view ............................................................ 103
Data logger content configuration ...................................... 104
Parameter window ......................................................... 105
Data logger trigger configuration ....................................... 106
Continue monitoring after using the data logger .................... 108
Uploaded data logger data .................................................. 108
Amplitude logger ............................................................ 109
Macro command ............................................................ 110
Macro ........................................................................ 110
Selecting control diagrams from the drive tree ..................... 116
Top level of a control diagram ......................................... 116
Lower level of a control diagram ...................................... 117
Zooming tool ............................................................... 117
FSO-11: Selecting Safety settings ....................................... 120
FSO-11: Fault FSO Fault 7A8B .......................................... 120
Typing the password ....................................................... 120
FSO-11 Validate dialog box .............................................. 121
Safety configuration ok message ....................................... 121
FSO-11: Parameter group 200 ........................................... 122
FSO-11: Save safety file button ........................................ 122
FSO-12: Selecting Safety settings ....................................... 123
FSO-12: FSO general fault 7A8B ....................................... 123
Typing the password ....................................................... 123
FSO-12 configuration in Safety group 200 .......................... 124
FSO-12 configuration with only group names ....................... 124
Validate dialog box ....................................................... 125
Safety configuration ok message ....................................... 125
FSO-12: Parameter group 200 ........................................... 125
FSO-12: Save safety file button ........................................ 126
Safety configuration report: Safety settings 2 -> Print configuration Report ......................................................... 127
Safety configuration report: Select print template .................. 127
Safety configuration report: Drive and FSO information .......... 127
Safety configuration report: List of configured safety functions ......................................................... 128
Safety configuration report: FSO commissioning check list .... 128
Safety configuration report: Print preview ........................... 129
Safety configuration report: Printer settings ........................ 129
Safety configuration report: Tools -> Safety Configuration Report ......................................................... 130
Safety configuration report: Select print file ......................... 130
Backup/restore command .................................................. 131
Drive parameter conversion – Introduction .......................... 133
Drive parameter conversion – Browsing the ACS800/600 file ......................................................... 134
Drive parameter conversion – Browsing the ACSX80 parameter file ......................................................... 134
Drive parameter conversion – Save target ........................................... 135
Drive parameter conversion – Results ............................................. 135
PSL2 Data logger ............................................................................ 136
Adaptive programming .................................................................... 137
Introduction to the manual

Contents of this chapter
This chapter contains information on the applicability, compatibility, target audience and the purpose of the manual. It also describes the contents of the manual.

Applicability
This manual applies to the Drive composer PC tool available in two different versions:
• Drive composer entry, DCET-01
• Drive composer pro, DCPT-01 (code: 3AUA0000108087).

Drive composer entry can be downloaded for free by navigating to www.abb.com/drives and selecting Drive PC Tools. Drive composer pro includes all features and is available through ABB sales channels. Both versions require registration.

Note: The features available only with Drive composer pro are indicated with (pro).

Target audience
The reader is expected to be an automation engineering professional or an electrician and familiar with drive products and the concepts regarding their commissioning and operation, including the parameter system of ABB drives. Also a basic knowledge of Microsoft Windows operating system is needed.

Purpose of the manual
This manual describes the Drive composer PC tool and instructs how to use it in the commissioning and maintenance of the ABB drives.
Contents

The manual consists of the following chapters:

- **Introduction to the manual** provides information on the applicability, compatibility, target audience and the purpose of the manual.
- **Overview of Drive composer** briefly lists the main features of the Drive composer software and instructs how and where it can be run, and how to get help and additional information.
- **Installation and uninstallation of Drive composer** describes how to install and uninstall the Drive composer software.
- **Connections** describes how to make a connection with a drive through USB or Ethernet.
- **Main user interface components** describes the main user interface components of the Drive composer PC tool, including the menus.
- **Parameter window** describes how to use the parameter window.
- **Monitor window** describes how to use the monitor window.
- **Workspace handling** describes the workspace functionality.
- **Event logger** describes how to use the event logger.
- **Diagnostics** describes how to troubleshoot a drive with the **Support package** button of Drive composer and the data logger included in the drive.
- **Control diagrams (pro)** describes how to use the control diagrams.
- **FSO configuration** contains the configuration procedure of the FSO-11 and FSO-12 safety functions with Drive composer pro and provides an example of how to configure the optional FSO-11 and FSO-12 safety functions module.
- **Other functions** describes functions that are common to many views, windows and functions that are not associated with any view or window.
### Terms and abbreviations used in this manual

<table>
<thead>
<tr>
<th>Term or abbreviation</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alarm limit of monitoring</td>
<td>You can set a low or high alarm limit for monitoring. Color(s) of the signal(s) change(s) on the monitoring graph area if the limit is reached.</td>
</tr>
<tr>
<td>Assistant</td>
<td>Provides predefined steps for setting the parameters of the drive. For example, the basic start-up assistant.</td>
</tr>
<tr>
<td>Assistant control panel</td>
<td>Control panel with an USB connector enabling a PC tool connection for common architecture drives. Assistant control panel is a generic name for ACS-AP-I and ACS-AP-S panels.</td>
</tr>
<tr>
<td>Autoscaling</td>
<td>Y-axis scaling is set automatically when this button is enabled. User-defined y-axis limits are then disabled.</td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong> Zooming is not possible in the Autoscaling mode.</td>
</tr>
<tr>
<td>Backup</td>
<td>Backup of the drive. Includes all parameters, application program, user sets. ACS880 memory unit consists of FW and all the files that belongs to backup. Primary method to replace a broken drive control board is to use the memory unit from the old one.</td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong> Backup does not include the firmware of the drive.</td>
</tr>
<tr>
<td>Basic control panel</td>
<td>Control panel with limited basic functionality used with common architecture drives.</td>
</tr>
<tr>
<td>Bit mask of monitoring</td>
<td>You can filter bits of the Status word and monitor them individually.</td>
</tr>
<tr>
<td>Common architecture drives</td>
<td>For example, ACS880 and ACS580.</td>
</tr>
<tr>
<td>Compare parameters</td>
<td>You can compare parameters between drives or between a drive and a file to find out differences.</td>
</tr>
<tr>
<td>Control diagrams</td>
<td>Graphical presentation of the drive reference chain or other function. Shows online values of a parameter, switch positions and signals. Parameters can be modified online. Functionality is not available for all drives.</td>
</tr>
<tr>
<td>Copy/Download parameters</td>
<td>Visible parameters of a parameter window or custom parameter window are copied/downloaded to a drive.</td>
</tr>
<tr>
<td>Cursor tool</td>
<td>Monitor window has a double cursor tool and the positions of cursors can be freely set in the monitor window. y2—y1 and x2—x1 differences are calculated.</td>
</tr>
<tr>
<td>Custom parameter window</td>
<td>You can create windows and drag drop (copy) parameters to these windows. You can also change parameter values in the window and save the changes for using in offline mode. The Filename extension for custom parameters is *.dccustparams.</td>
</tr>
<tr>
<td>Data file viewer</td>
<td>In the Demo/Offline mode, the monitor window can be used as a data file viewer when saved monitored data (*.dcmon) or data logger data is analyzed.</td>
</tr>
<tr>
<td>Data logger</td>
<td>Signals are buffered inside a drive with a fast sample interval. Can be triggered and uploaded to the monitor window to be analyzed.</td>
</tr>
<tr>
<td>Demo/Offline</td>
<td>In Demo mode you can view the default parameter values and settings. In Offline mode you can set/view the saved parameter files offline.</td>
</tr>
<tr>
<td>DriveAP</td>
<td>Adaptive Programming of a drive. Functionality of a drive can be modified by adding some IEC 61131 -based blocks. Adaptive Programming can be done also with an Assistant control panel.</td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong> Adaptive Programming is not available with all drives.</td>
</tr>
<tr>
<td>Term or abbreviation</td>
<td>Explanation</td>
</tr>
<tr>
<td>------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Event logger</td>
<td>Can consist of faults, alarms and events. Only faults stop the drive. Latest faults and alarms are also seen in parameter interface group 4, Warnings and Faults.</td>
</tr>
<tr>
<td>FENA-11</td>
<td>Ethernet adapter module for ABB drives.</td>
</tr>
<tr>
<td>LOC/REM</td>
<td>LOC denotes local control of the drive, either with an Assistant control panel or the Drive composer PC tool. REM means that the drive is remotely controlled by the fieldbus master PLC or by I/O connections.</td>
</tr>
<tr>
<td>Lock/Unlock parameter</td>
<td>Parameter can be locked by a drive. You can only view the parameter values, but cannot modify them.</td>
</tr>
<tr>
<td>Macro script</td>
<td>User-written sequence of macro statements for reading and writing parameters/signals. Filename extension for macro scripts is *.p.</td>
</tr>
<tr>
<td>Monitoring</td>
<td>You can set parameters or signals to the monitor window. Values are collected with the sampling interval and drawn to a window.</td>
</tr>
<tr>
<td>NLS support</td>
<td>National Language Support, the user interface (UI) of Drive composer can be easily modified by editing language files found in the LANG folder of the Drive composer PC tool.</td>
</tr>
<tr>
<td>Online/Offline</td>
<td>Online = PC tool is connected with the drive. Offline = PC tool is not connected with the drive. In the Offline mode it is possible to open parameter files, save monitored data etc.</td>
</tr>
<tr>
<td>OPC server</td>
<td>OPC DA server interface for Drive composer pro that allows other programs, such as Control Builder Pro (Advanced drive programming), to communicate with the drive.</td>
</tr>
<tr>
<td>Refresh the parameter</td>
<td>Parameter values are updated when a group is opened. You can set parameters to the Auto-update mode or refresh the value manually. Signals are always updated automatically. Signals are bolded in the parameter list.</td>
</tr>
<tr>
<td>Report</td>
<td>You can use report templates for energy savings, commissioning and maintenance. Templates can be modified.</td>
</tr>
<tr>
<td>Restore</td>
<td>You can restore the drive. You can select the parameters to be restored during the restore operation. For example, motor identification run results can be restored or deleted during the restore operation. Can be used for cloning drives.</td>
</tr>
<tr>
<td>Save parameters</td>
<td>Visible parameters of a parameter window or custom parameter window are saved to a file. Filename extension for saved parameters is *.dcparamsbak.</td>
</tr>
<tr>
<td>Note: Some values are not editable in the Offline mode.</td>
<td></td>
</tr>
<tr>
<td>Support diagnostics package</td>
<td>You can collect all data from a drive for troubleshooting purposes by clicking a button in Drive composer or on an Assistant control panel.</td>
</tr>
<tr>
<td>Workspace</td>
<td>Workspace consists of the user interface status, such as parameters shown in the custom parameter window(s) and their status. You can save the current workspace status to a file and restore it later. Custom parameter windows with their contents and the monitor window contents (signals selected, scalings, colors) are saved to a workspace. You can set one default workspace. Filename extension for the workspace is *.dcxml.</td>
</tr>
</tbody>
</table>
Overview of Drive composer

Contents of this chapter

This chapter briefly lists the main features of the Drive composer software and instructs how and where it can be run, and how to get help and additional information.

Drive composer

Drive composer is a 32-bit Windows application for commissioning and maintaining ABB common architecture drives.

The full version is called Drive composer pro and the limited version is called Drive composer entry.

Both versions include a demo that allows testing user interface functionality, edit parameter files offline (pro) or open and analyze saved monitored files without connecting to a physical drive.

Compatibility

Drive composer is a software tool for ABB all-compatible drives and devices. The main products are, for example, ACS580 and ACS880 drive families.

Drive composer entry offers the basic features that are common to all-compatible drives. The connection from Drive composer entry to a drive with an Assistant control panel is also supporting commonly for all the drives and devices.

Drive composer pro offers a variety of features and software modules whose availability is also dependent on connected drives and option modules. Drive composer pro recognizes the connected drives based on the type code and firmware version and then adapts the availability of features accordingly. For non-recognized but all-compatibles drives, the same common basic features are available than with Drive composer entry.
Drive composer pro has a limited support (parameter editing and monitoring) for ACS800. It requires DriveWindow 2.40 installation on the same PC.

**Highlights**

With Drive composer, it is possible to:
- control a drive: start, stop, direction, speed/torque/frequency reference
- monitor the operation and status of a drive
- view and adjust drive parameters
- monitor signals in numerical and graphical (trending) format
- work simultaneously with multiple drives like master and follower drives (pro)
- display control diagrams of a drive for parameter setting and diagnostic purposes (pro)
- create user-specific workspaces by customizing parameter windows
- configure the optional FSO-11 and FSO-12 safety functions module (pro)
- handle workspaces
- create and execute macro scripts (pro)
- use Ethernet-based fieldbus adapter modules for PC tool communication (one-wire solution, Profinet, Ethernet IP) (pro) or a drive-embedded Ethernet port
- use the USB port of an Assistant control panel for an USB connection
- use an OPC-based commissioning and maintenance tool (pro).
# Features

<table>
<thead>
<tr>
<th>Feature</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Feature</th>
<th>Drive composer entry</th>
<th>Drive composer pro</th>
</tr>
</thead>
<tbody>
<tr>
<td>Parameters can be modified</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Parameters can be searched</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Parameters changed by the user (or automatically updated) have an orange background</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Parameters can be saved to a file</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Parameters can be copied/downloaded to a drive</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Parameter windows can be customized</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Parameters can be printed</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Parameters can be edited offline</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>Parameters can be compared between parameter lists or drives</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>Data for the support service can be collected by clicking the Support package icon</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>As a simple monitoring method for basic purposes, up to 8 signals can be monitored</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Monitored data can be saved to a hard drive of a PC</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Monitored data can be exported to a PC by using the tab separated file</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>For a professional analysis of a single drive or multidrive, maximum 26 signals can be monitored</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>Contents of an event logger (faults, warnings) can be viewed</td>
<td>Partly</td>
<td>Yes</td>
</tr>
<tr>
<td>Contents of the System info (drive serial number, modules, versions, SW etc.) can be viewed</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Full backup/restore can be used for restoring or cloning a drive</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Full backup/restore of multidrives can be used for restoring or cloning in a network of drives</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>PC can be used to analyze the data logged in a drive by a data logger</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>Macro scripts can be created and executed</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>Safety settings can be configured to a safety functions module (FSO)</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>Point-to-point USB can be connected through a panel port</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Network drives can be connected via Ethernet or with a panelbus</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>Control diagrams of a drive can be used for parameter setting and diagnostic purposes</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>User interface is available in different languages</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Create and edit Adaptive Programs</td>
<td>No</td>
<td>Yes</td>
</tr>
</tbody>
</table>
Hardware and software requirements

- **Drive composer hardware**
  - USB type A (PC) type mini B (panel) cable for connecting Drive composer entry/pro through the USB port of the control panel to a drive (max 3 m)
  - **Note:** We recommend ferrite core cables.
  - Ethernet cable RJ45 if the connection is made through the FENA-11 or embedded Ethernet

- **Computer hardware**
  - IBM compatible PC
  - Pentium 2000 MHz or a faster processor (Dual-core or better recommended)
  - 1GB RAM
  - 1024 x 600 display resolution with 256 colors
  - At least 150 MB free hard disk space
  - CD drive
  - One free USB port or Ethernet port

- **Software**
  - Operating system Windows XP, Vista, Windows 7 or Windows 8 (32- or 64-bit operating system)
  - Microsoft.NET Framework 4.5.1 is required for Windows 7/Windows 8 or 4.0.3 for Windows XP.

**Note:** Update the latest version of Microsoft.NET Framework on your PC.
Installation and uninstallation of Drive composer

Contents of this chapter
This chapter describes how to install and uninstall the Drive composer software.

Determining the current Drive composer version
To know the version of the Drive composer PC tool, select About the product in the Help menu. The About the product dialog box displays the Drive composer version.

Figure 1. About the product dialog box
Installing Drive composer with the installer

It is recommended to uninstall all previous versions of Drive composer before installing a new version. Close all applications before starting the installation.

1. Run the `setup.exe` file from the folder where you unzipped the Drive composer files.
2. With Windows 7, right-click on the `setup.exe` file and select Run as administrator.

3. In the Drive composer pro - InstallShield Wizard, click Next >.

---

**Figure 2. Run as administrator**

**Figure 3. Drive composer setup wizard window**
4. Choose the destination folder and click **Next >**.

![Destination folder window](image)

**Figure 4. Destination folder window**

5. Click **Install** to start the installation.

![Installation window](image)

**Figure 5. Installation**
If Drive composer installation is complete, click **Finish**. Now the Drive composer is ready for use.

![Installation Complete window](image)

*Figure 6. Installation Complete window*
Uninstalling Drive composer with the installer

1. In the **Control panel** —> **Programs** —> **Program and features** window, select the installed Drive composer pro program and click **Uninstall**.

![Figure 7. Removing Drive composer](image)

2. Click **Yes** to uninstall Drive composer pro application.

![Figure 8. Confirming the removal of Drive composer](image)
Registration

Drive composer pro includes a license and requires registration. During the first launch of the software, preferably the registration can be made online. You can also make offline registration in case of no Internet connection is available on the PC where Drive composer is installed.

You can also run Drive composer pro for 30 days in fully functional evaluation mode.

- **Online registration**

  During the first launch of Drive composer pro, a prompt for license key appears.

  ![Product activation](image)

  **Figure 9. Online activation**

  Fill in the license key and click **Activate**. You are forwarded to registration form. Fill the details accurately and proceed with registration.

- **Offline registration**

  To make offline registration, contact your local ABB representatives and provide the following details.
  - Name of the registrar
  - E-mail address
  - Company name
  - Field of industry (optional)

  **Note:** Offline registration is only possible during 30 days evaluation period.

  After manual registration process by ABB support personnel, you will be provided a license file that you can use for offline registration. Go to **Help --> Import licence file**, fill in the license key and use the license file provided.

  ![Import licence file](image)

  **Figure 10. Import licence file**
Connections

Contents of this chapter
This chapter describes how to make a USB connection or an Ethernet connection to an ABB drive with Drive composer.

Assistant control panel drivers
You can connect an ABB drive to an Assistant control panel (ACS-AP-x) through USB by installing the required USB device drivers. Drive composer installer installs the required drivers automatically, so no user actions are needed.

In case of any problems with automatic installer the USB drivers can be manually installed by downloading the tool from software tools website:

Follow the instructions provided with the drive package.
Connecting to a drive with an Assistant control panel for the first time

To establish a connection between Drive composer and drive, connect a USB type A (PC) type mini B (panel) cable to the USB port of the computer and the USB port of the Assistant control panel (ACS-AP-x panel). The maximum length of the USB cable should be 3 m. If the drive is used without an Assistant control panel or with a Basic control panel, use separate USB/485 adapter to establish connection between Drive composer and drive.

1. Connect your PC to the Assistant control panel with a USB cable.

![Diagram of USB connection between Assistant control panel and PC]

The following text appears on the Assistant control panel screen: "USB connected".

**Note:** The Assistant control panel cannot be used when it is connected to a PC.

2. Launch Drive composer by double-clicking Drive composer entry/pro.exe.

3. Click **Connect** if you want to connect to the drive or click **Demo** if you want to choose the Offline mode. You can also select the dedicated connections to the drive:

![Image of Drive composer software with Connect/Demo button]

**Figure 2. Connect/Demo button**
• DDCS enabled (ACS800 only) - Connects to the drive through DDCS (fiber optic) communication. This option is applicable to ACS800 drive type only.

• USB/COM enabled - Connects to the drive through USB connection. Use this option only when you want to connect to the drive through serial connection, example, USB cable to ACS-AP-x panel.

• Ethernet enabled - Connects to the drive through Ethernet network

• Comm settings - Opens another dialog where you can configure the connections in more detail other than the above three options.

Note:
• The status LED starts flickering in the Assistant control panel indicates data transfer between drive and PC. The LED keeps blinking as long as there is a PC tool connected to the drive. The welcome dialog box is shown on the screen indicating that the application is being initialized.

• First time connection, parameter texts are loaded from the drive and this might take few minutes depending on the drive type.

Drive composer loads parameters and the following window displays.

![Figure 13. Parameters loaded](image)

You have now an online connection to the drive. If you have a single drive and a point-to-point connection, move to chapter Parameter window.

4. If you failed to make an online connection to the drive, go to View -> Settings to check your COM settings and click View -> Refresh (Ctrl + R) to reconnect Drive composer to the drive.
Changing the language settings

1. To change the language settings of the Drive composer UI, go to View –> Settings.

![Figure 14. View-Settings](image)

2. In the Settings window, choose the required language for the Drive composer UI.

![Figure 15. Language settings](image)

- **Drive composer default language** to choose the default language of the menu or button text in Drive composer.
- **Drive default language** to choose the default language for parameters.

By changing language settings you can always use the same language when you connect Drive composer to the drive.

3. After changing the language settings click View –> Refresh (Ctrl + R) or restart the Drive composer application.
Note: Some elements might require application restart to update the selected language.
Connecting to a drive via an Ethernet network

- **Ethernet network connection**

There are ABB drives which have control boards with an embedded Ethernet port and ABB drives in which the Ethernet connection is made with the FENA-11 Ethernet adapter module. For the installation of the adapter module, see *FENA-01/-11 Ethernet adapter module user’s manual* (3AUA0000093568 [English]).

**Note:** The PC/Ethernet Switch firewall must be configured to allow a connection for Drive composer pro (port http 80 and UDP) or the firewall must be disabled.

- **Creating an Ethernet network connection with Drive composer (pro)**

1. Connect the FENA-11 to a drive.
2. Create a point-to-point connection from Assistant control panel or Drive composer to each drive.
3. If you use one adapter module with a drive, enable the FENA-11 by setting parameter 50.01 FBA A enable to *Enable* and parameter 50.21 FBA A Timelevel sel to *Fast* (or *Monitoring* for Tool network only).
4. If you use two fieldbus adapters with the drive and the FENA-11 has been installed as FBA B, enable the FENA-11 by setting parameters 50.31 FBA B enable to *Enable* and 50.51 FBA B Timelevel sel to *Fast* (or *Monitoring* for Tool network only).
5. Set a static IP address for each drive. See *FENA-01/-11 Ethernet adapter module user’s manual* (3AUA0000093568 [English]).

![Figure 16. IP settings of the drive with Drive composer](image)

6. Refresh the settings with parameter 51.27 FBA par refresh.

**Note:** Refreshing the Node setting will lose the communication to the drive. To re-establish the connection with the drive, select **View -> Refresh**.

7. Name each drive to facilitate the recognition of drives when creating an Ethernet network connection.
   - If you use Drive composer, name the drives on the System info tab by typing the name to the Drive name field and clicking **Set**.

![Figure 17. Naming a drive with Drive composer](image)
Connections

Note: The drive name changes after the view has been refreshed. The previous names in other existing workspaces are not affected. If you use Assistant control panel, name the drives through the Setting menu of the panel.

8. Configure the TCP/IP address of your PC. In this example the TCP/IP address is 192.168.0.1. For more information on configuring the TCP/IP address, see Configuring the TCP/IP address with Windows XP or Configuring the TCP/IP address with Windows 7.

Configuring the TCP/IP address with Windows XP

1. Go to Control panel → Network and Internet Connections → Network Connections.

2. In the Network Connections window, double-click the required connection.

![Network Connections window](image)

Figure 18. Network Connections window
3. Click the **Properties** button. The Local Area Connection Status dialog box appears.

![Local Area Connection Status dialog box](image19)

**Figure 19. Local Area Connection Status dialog box**

4. Select **Internet Protocol (TCP/IP)** and click **Properties**.

![Local Area Connection Properties dialog box](image20)

**Figure 20. Local Area Connection Properties dialog box**
5. Select **Use the following IP address** and type the IP address and the subnet mask. Click **OK**.

Figure 21. Use the following IP address option selected
TCP/IP address configuration is completed.
Configuring the TCP/IP address with Windows 7

1. Go to Control Panel and click View network status and tasks.

2. Click Change adapter settings on the left pane. A Network connections window displays.
3. Double-click **Local Area Connection**.

![Image of Local Area Connection]

*Figure 24. Local Area Connection*

4. Click **Properties**.

![Image of Local Area Connection Status dialog box]

*Figure 25. Local Area Connection Status dialog box*
5. Select Internet Protocol Version 4 (TCP/IPv4) and click OK.
6. Select **Use the following IP address**, type the IP address and subnet mask and click **OK**.

![Internet Protocol Version 4 (TCP/IPv4) Properties](image)

*Figure 27. Selecting the IP address and subnet mask*

7. Connect the RJ45 cable between the FENA-11 and the PC. Alternatively, connect all drives and the PC to the same Ethernet switch.
8. Open command prompt (cmd.exe) and ping all the drives that you have configured.

```
C:\>ping 192.168.0.11
Pinging 192.168.0.11 with 32 bytes of data:
Reply from 192.168.0.11: bytes=32 time<1ms TTL=128
Reply from 192.168.0.11: bytes=32 time<1ms TTL=128
Reply from 192.168.0.11: bytes=32 time<1ms TTL=128
Reply from 192.168.0.11: bytes=32 time<1ms TTL=128
Ping statistics for 192.168.0.11:
   Packets: Sent = 4, Received = 4, Lost = 0 (0% loss).
   Approximate round trip times in milli-seconds:
       Minimum = 0ms, Maximum = 0ms, Average = 0ms
```  

Figure 28. Pinging drives

**Note:** You must open http port 80 of the firewall on your PC to enable Drive composer pro to communicate with drives.

9. Open Drive composer pro.

Drive composer scans all COM ports and Ethernet ports to find drives.

If problems arise, see *Ethernet tool network for ACS880 drives application guide* (3AUA0000125635 [English]).
Connecting network drives (pro)

- Panel bus network connection

ABB drives with an ACS-AP-x panel can be daisy-chained through the control panel ports as a network either for a PC tool or a panel bus connection.

Note: Some ABB drives control boards (for example, ZCU-13) do not have any daisy-chain connectors. For those drives, a panel bus connection can be created with FDPI-02 option modules. See *FDPI-02 diagnostics and panel interface user’s manual* (3AUA0000113618 [English]) for more information.

Figure 29. Creating a panel bus

- Creating a panel bus with Drive composer (pro)

1. Create a point-to-point connection from the Assistant control panel or Drive composer to each drive.

2. Set an independent node ID for each drive (with parameter 49.01 Node ID number). The node ID must be between 1…32.

3. Refresh the settings (with parameter 49.06 Refresh settings).

Note: Refreshing the Node setting will lose the communication to the drive. To re-establish the connection with the drive, select View -> Refresh.

4. With parameter 49.05 Communication loss action, define how the drive reacts to a control panel (or PC tool) communication break by selecting No action.

5. Give a name for each drive to facilitate the recognition of drives when creating a panel bus connection.

<table>
<thead>
<tr>
<th>49. Panel port communication</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
</tr>
<tr>
<td>3</td>
</tr>
<tr>
<td>4</td>
</tr>
<tr>
<td>5</td>
</tr>
<tr>
<td>6</td>
</tr>
</tbody>
</table>

Figure 30. Panel port settings with Drive composer
If you use Drive composer, name the drives on the System info tab by entering the name to the Drive name field and clicking **Set**.

![Drive name: ZCU12_1, Set, 2/19/2013 10:13:48 PM](image)

**Figure 31. Naming a drive with Drive composer**

- **Note:** The drive name changes after the view has been refreshed. The previous names in other existing workspaces are not affected.

If you use Assistant control panel, name the drives through the Setting menu of the panel.

6. Remove all panels connected to drives.

7. To daisy-chain the drives connect a standard RJ45 (straight CAT5) cable to the left-hand side connector of the Assistant control panel in the first drive (the left-hand side drive in figure *Creating a panel bus* on page 41).
   - **Note:** Heavy-industry type RJ45 male connectors do not fit into the drive side female RJ45 slot

8. Connect a standard RJ45 (straight CAT5) cable from the right-hand side connector of the Assistant control panel in the first drive to the left-hand side connector of the Assistant control panel in the second drive.

9. Continue chaining the rest of the drives as described above.

10. If there is a long distance between the first and last drive in a panel bus, set the resistor to the ON position in the last node.

### Connecting to the panel bus with Drive composer (pro)

1. Connect a USB cable between the Assistant control panel and your PC.

2. Double-click **Drive composer pro.exe** to launch Drive composer.
   - The status LED starts flickering on the Assistant control panel.
   - **Note:** It may take a long time before all drives are found.
   - **Note:** Drive composer does not open automatically any parameter window or other object.

3. Make sure you see all the drives in the Drive list.
   - **Note:** If you do not see all the drives, close the PC tool and try again. If you still do not see all drives, check Group 49 Panel port communication for the settings of the missing drives.

4. Select and click a drive from the Drive list.
Connection sharing (pro)

Select the option **Share connection with Control Builder Plus** to enable the simultaneous connection to the same drive from both applications.

![Figure 32. Connection sharing](image)

*Figure 32. Connection sharing*
Main user interface components

Contents of this chapter
This chapter describes the user interface (UI) components and how to use them.

Overview
The user interface consists of the following parts:
1. Title bar
2. Menu bar
3. Drive control panel
4. Drive list
5. Status panel (including the output view of the selected drive)
6. Working area for parameter windows, event logger, control diagrams, assistants etc.

The working area can be used either with tabs or floating windows. The figure below shows the user interface with tabbed windows.

The size of the drive list can be adjusted to the left/right. Similarly, the size of the working area can be adjusted by dragging the white separating line up/down. Most of the windows that are not maximized can be resized by dragging any corner. Scroll bars appear on the side or bottom of a window if it is possible to scroll the content.
Main user interface components

Figure 33. Overview of the user interface

Title bar

The title bar is located at the top of the main window. It consists of the following parts:

- System menu icon
- Application name and version number (Drive composer entry/pro)
- Name of the workspace (if there is an active workspace)
- Minimize button which has the same function as Minimize in the System menu
- Maximize/Restore Down button (the name depends on the status of the maximized window) which has the same function as Maximize or Restore in the System menu
- Close button which has the same function as Close in the System menu.

Note: When you close the application, system prompts to confirm. Click Ok to close the application.

Figure 34. Title bar

To reduce the main window to the taskbar or a sub-window to the bottom of the window area, click the Minimize button or go to System menu → Minimize.

To enlarge the window to fill the available space, click the Maximize button or go to System menu → Maximize.

To restore the window to the size and position it had before it was maximized, click Restore Down button or go to System menu → Restore.

You can also maximize or restore the window by double-clicking the title bar.
To move a window, drag the title bar. To move a dialog box, drag its title bar. If you have maximized or minimized a window, you cannot move it by dragging the title bar.

To end your Drive composer session, click the **Close** button. Before closing down, Drive composer may:
- warn you about releasing control of the drive if the drive is controlled locally by Drive composer
- prompt you to save the workspace with unsaved changes
- remind you to save your monitor data
- remind you of unfinished printing.

**Note:** If you disconnect cable from the drive *before* closing Drive composer there might be long delay in operation.

**Note:** To disable the function prompting you to save the workspace with unsaved changes, go to **View → Settings**.

![Figure 35. Save workspace on exit function](image)

You can close Drive composer by
- double-clicking the **System menu** icon
- selecting **Close** in the System menu
- selecting **Exit** in the File menu
- pressing the shortcut key Alt+F4.
Main user interface components

System menu

You can open the System menu by
• left or right-clicking the System menu icon
• pressing the shortcut key Alt+space bar
• right-clicking within the non-button area of the title bar.

Figure 36. System menu

The System menu contains the following commands:
• **Restore** which has the same function as the Maximize/Restore Down button in the title bar when the window is maximized. The Restore command restores the window to its size and position which it had before it was maximized.
• **Move** which can be performed also by dragging the title bar. After selecting the Move command from the System menu, it is possible to move the window with the arrow keys. To stop moving the window, press Enter. To cancel the move, press Esc.
• **Size** which can be performed also by dragging any of the sides or corners of the window. After selecting the Size command, it is possible to resize the window with the arrow keys. To stop resizing the window, press Enter. To cancel resizing, press Esc.
• **Minimize** which has the same function as the Minimize button in the title bar. The Minimize command reduces the window to the taskbar or to the bottom of the window area.
• **Maximize** which has the same function as the Maximize button in the title bar when the window has not been maximized. The Maximize command enlarges the window to fill the available space.
• **Close** which has the same function as the Close button in the title bar. The Close command ends the Drive composer session.
Menu bar

The menu bar is located below the title bar. It contains the following drop-down main menus:

- File
- Edit
- View
- Tools (pro)
- Help.

To execute a command from a menu, click its name on the menu. You can also use the arrow keys to navigate between the menus. To execute a highlighted command, press ENTER. To close a menu, press the ESC key. You can also use the shortcut keys to execute the commands.

File menu

The File menu is always located in the menu bar.

![File menu](image1)

**Figure 37. File menu**

The File menu contains the following commands:

- **New..** opens a window where you can select a custom parameter set window. The keyboard shortcut for the custom parameter set command is Ctrl+N.

![File menu](image2)

**Figure 38. Custom parameter set**
Main user interface components

- **Open..** opens a new dialog.

<table>
<thead>
<tr>
<th>Command</th>
<th>Keyboard Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open the latest saved workspace</td>
<td>Ctrl+L</td>
</tr>
<tr>
<td>Open workspace</td>
<td>Ctrl+O</td>
</tr>
<tr>
<td>Monitor file</td>
<td>Ctrl+M</td>
</tr>
<tr>
<td>Parameter file</td>
<td>Alt+P</td>
</tr>
<tr>
<td>Custom parameter file</td>
<td>Alt+W</td>
</tr>
<tr>
<td>Open support package</td>
<td></td>
</tr>
</tbody>
</table>

**Figure 39. Open command**

- **Open the latest saved workspace** opens the latest saved workspace. The keyboard shortcut for the open latest saved workspace command is Ctrl+L.

- **Open Workspace** opens a new window where you can select the saved workspace to be opened. The keyboard shortcut for the Workspace command is Ctrl+O.

- **Monitor file** opens a window to open the parameter file for monitoring.

- **Parameter file** opens a new window where you can select the saved parameter file to be opened. The keyboard shortcut for the Parameter file command is Alt+P.

- **Custom parameter file** opens a new window where you can open the saved custom parameter file. The keyboard shortcut for the Custom parameter file command is Alt+W.

- **Open support package** opens a new window where you can select the saved support package file to be opened.

- **Save workspace** saves the active workspace to a file. The keyboard shortcut for the Save workspace command is Ctrl+S.

- **Save workspace as default** saves the active workspace to default workspace. The default workspace opens automatically when Drive composer is opened. The keyboard shortcut for the Save workspace as default command is Ctrl+D.

- **Print** menu prints the parameter screen.

- **Print real-time monitor view (pro)** prints the monitor screen.

- **Exit** ends the Drive composer session.
- **Edit menu**

The *Edit menu* is always located in the menu bar.

![Drive composer entry v.1.0.7.1 RC1](image)

**Figure 40. Edit menu**

The menu contains the language commands with which you can select the language for the Drive composer user interface.

**Note:** Restart the Drive composer to see the language changes.
Main user interface components

View menu

The View menu is always located in the menu bar.

The View menu contains the following commands:

- **Normal text font size** for selecting the normal font size. The keyboard shortcut for Normal text font size is Ctrl+F6.
  
  **Note:** The change in the font size does not affect the size of the monitor window font.

- **Large text font size** for selecting the larger font size. The keyboard shortcut for Large text font size is Ctrl+F7.

- **The largest text font size** for selecting the largest font size. The keyboard shortcut for the largest text font size is Ctrl+F8. The font sizes can also be changed with the following A-letter icons.

- **Tabs** for changing the working area to be viewed as tabs. The keyboard shortcut for Tabs is Alt+T.
  
  **Note:** The monitor window cannot be tabbed.

- **Floating windows** for changing the working area in a separate window. The keyboard shortcut for Floating windows is Alt+F.
  
  **Note:** The monitor window cannot be a floating window.

- **Tile horizontally** for changing floating windows to be tiled horizontally. The keyboard shortcut for Tile horizontally is Alt+H.

- **Tile vertically** for changing floating windows to vertical. The keyboard shortcut for Tile vertically is Alt+V.
Main user interface components

- **Cascade** for changing floating windows to cascade. The keyboard shortcut for Cascade is Alt+C. The cascaded windows can be resized and freely located in the working area.
- **Refresh** for creating a new connection to the drive (uploads parameter information from a single drive and creates a new connection with multidrives). The keyboard shortcut for Refresh is Ctrl+R.
- **Settings** for defining language, connection configuration, workspace settings, local control disable and temporary files location.

**Tools menu (pro)**

The Tools menu is located in the menu bar. The commands of the Tools menu vary between SW versions and drives.

![Figure 43. Tools menu](image)

The menu contains the following commands:

- **Safety Configuration Report** for printing the safety functions configuration report with FSO-12 installed. This option is available only in Drive Composer version 1.7 and later.
- **Backup network** for creating backup of all connected drives in a PC tool network. The keyboard shortcut for Backup network is Ctrl+B.
- **Compare drive data** for comparing parameters of two drives or a parameter file and a drive or two parameter files. The keyboard shortcut for Compare drive data is Alt+C.
- **PSL2 data logger** for uploading PSL2 data logger files from the drive flash memory to PC local hard drive. This option is applicable only in BCU-x2 control unit.
- **Drive Parameter Conversion Tool** to convert the parameters.
- **EDS Export** for creating the EDS files of a connected drive. The keyboard shortcut for EDS Export is Ctrl+I.
- **Application symbols** for showing the symbols exported from Control Builder Plus application for the drive. If the drive does not have Control Builder Plus, the application list remains empty. The keyboard shortcut for showing the application symbols is Ctrl+A.
Help menu

The Help menu is always located in the menu bar.

The Help menu contains the following commands:

- **Content** or the F1 key opens the Drive composer user manual as a PDF file.
- **Firmware manual** or the F3 key opens the firmware manual of the drive in a separate window as a PDF file. If you have selected a parameter or some other significant item when you click this command or press the F3 key, the appropriate chapter in the firmware manual is displayed.
- **Make support package** function creates a single file, that can be sent to local ABB support contact in case of any need for support.
- **Import licence file (pro)** function displays the Product activation window. Enter the activation key and click Activate.
- **About the product** opens a window displaying the program information, version number and copyright text.
Main user interface components

Drive control panel

The drive control panel is located below the menu bar. It has buttons for controlling a connected drive. It also shows the status of the drive.

![Drive control panel](image)

**Figure 45. Drive control panel**

The drive control panel contains the following buttons and items:

- Name and node number of the currently controlled drive and an indication if it is running. See below for status icons explanations.
- **Control** button controls the selected drive with Drive composer or releasing the control of the drive.
- **Reset fault** button sends a reset command to the drive. If the fault is no longer active, the drive clears it.
- **Start** button starts the currently controlled drive. A motor connected to the drive starts rotating according to the set reference value.
- **Stop** button stops the rotation of the motor connected to the currently controlled drive.
- **Coast stop** button.
- **Reference** value field enables entering a new reference value. When you click the Reference field, a tooltip tells you max and min limits for the reference and current reference value.
- Reference field shows the reference used in the drive. The reverse direction is set manually with the - sign.
- **Set** button enforces the value in the reference value field to the currently controlled drive. The same command can be performed by pressing Enter.
- **Active reference** displays the reference value.
- **Step configuration** cycle button enables to modify Step type, Step value and Step duration with reference value. The available configuration is dependent on the connected drive.
- **Step** functionality activates the step cycle with the reference value.
Main user interface components

- **Drive list panel**

  The drive list panel shows all connected drives and open files. Drives are indicated with a motor icon (clockwise open circle arrow).

  ![Drive list panel in Drive composer pro](image)

  A grey circle arrow indicates a stopped drive.

  ![Stopped drive](image)

  A green circle arrow indicates a running drive.

  ![Running drive](image)

  A red circle with a white cross (x) indicates a faulty drive.

  ![Faulty drive](image)

  An orange background means that a drive that has an alarm.

  ![Drive with an alarm](image)
A red broken line (—/-/—) means that the connection to a drive has broken.

**Figure 51. Drive with a broken connection**

The views for a drive — parameter window, data logger, event logger, system info, assistants (if such are available for the drive), control diagrams (if such are available for the drive) — can be seen by clicking with the primary mouse button and selecting the corresponding icons from the pop-up window.

You can open those views either as new tabs or floating windows. If an active window is associated with a drive or a file, the corresponding tree item is highlighted in the drive list.

#### Using the drive control panel for starting the drive

1. See the firmware manual of the drive for parameters you must set before starting.
2. Click the **Control** button.
   - The control box indicator changes to LOC.
3. Enter a reference value and press Enter or click the **Set** button.
4. Click **Start**.
   - The drive starts. The indicator box arrow changes to green.

**Note:** Limit settings in group 30 affect reference limits.
Main user interface components

Working area

Parameter windows, custom parameter windows, event logger, system info, control diagrams, assistants etc. are shown in the working area. The user interface is tabbed by default. You can change the order of tabs by dragging them. You can open tabs for a single drive or for multiple drives.

Figure 52. Tabbed user interface

The working area can be set to a floating window. For example, parameter window, event logger, system info etc. are shown as floating windows. The floating windows can be tiled vertically or horizontally or cascaded by using the commands in the View menu.

Figure 53. Floating windows
Parameter window

Contents of this chapter
This chapter describes the parameter and custom parameter windows.

Parameter window
With Drive composer entry the parameter window is always opened when you make connection to a drive. With Drive composer pro the parameter window is opened by clicking on the selected drive in the drive list and selecting Parameters.

The parameter window view displays parameter groups, parameters and their values for the associated drive or a file. There can be several parameter windows in the working area. The headline of each parameter window shows which drive it belongs to.
Following are the command icons available in the parameter window.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Expands/collapses parameter groups. When parameter groups are expanded, all parameter values are read once from the drive.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Saves parameters to a file. Saves visible parameters to a file. File extension is dcparams(bak).</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Enables you to search parameter lists with a keyword. Search is activated/deactivated by clicking the Filter check box. When the Filter check box is unchecked all parameters are seen. <strong>Note:</strong> If parameter groups have not been expanded, the first search takes about 30…60 seconds.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Allows you to select/deselect columns to be seen in a parameter window.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Parameters are updated only when a group is opened. With the Enable updating function it is possible to set all open and visible groups to be updated automatically. Parameters that have been set to be updated automatically have a yellow background.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Allows you to download parameters from a file to a drive. With a custom parameter window allows downloading offline values to a drive.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Enables you to change the window target, which is useful if you have Drive composer pro and you have to check certain parameters of another drive. Included only in custom parameter windows.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Provides you with a list of all user-changed parameters if you click the check box. These parameters have an orange background.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Allows you to add or remove one parameter or signal or several parameters or signals to/from a custom parameter window.</td>
</tr>
</tbody>
</table>
Figure 54. Parameter window
The parameter window contains different types of parameters. Some of these types are identified by colors or bold fonts as shown in the table below:

<table>
<thead>
<tr>
<th>Illustration</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>20.3 Ext1 In1 source</td>
<td>D1 Normal parameters</td>
</tr>
<tr>
<td>1.1 Motor speed used</td>
<td>0.00 rpm Signals (bold)</td>
</tr>
<tr>
<td>10.21 RO status</td>
<td>Bit names of a parameter can be seen by double-clicking on the parameter. New window opens.</td>
</tr>
<tr>
<td>11.6 DIO1 output source</td>
<td>P.10.1.1 Parameter value is set from another parameter, for example, parameter group 10, index 1, bit 1.</td>
</tr>
<tr>
<td>11.6 DIO1 output source</td>
<td>P.10.1.1 - Parameter value is an inverted bit of another parameter, group 10, index 1, bit 1.</td>
</tr>
<tr>
<td>20.1 Ext1 commands</td>
<td>in1 Start User has changed the value of a parameter (shown with an orange background).</td>
</tr>
</tbody>
</table>

The most common type is the regular parameter. Parameters are normally readable and writable. However, when the drive is running, some parameters may be write-protected.

Parameter names, values, units, default values and different user sets are shown in the parameter window. The number of user sets depends on the drive type.

The value of a parameter is read only once. If you want to update this value, right-click and select Refresh the parameter. You can set all visible parameters to update automatically by clicking the Enable updating button.

The values of signals cannot be modified. If signals are modified, you will get an error prompt for every signal. Signals are updated cyclically in the parameter window. Parameter signals are also updated frequently, but their values can be modified.

Navigating parameters and groups

Parameter values are updated if they are modified. A parameter value can be modified by double-clicking the parameter or by pressing Enter on a highlighted parameter. To update parameter group values, right-click the group name and select Refresh group parameters.

In special cases, hidden parameters and groups become available by modifying some parameter values, the View → Refresh command updates the whole parameter table. An example for such a group is group 51 FBA A Settings: When the adapter module has been enabled in group 50, the parameter names can be seen by selecting View → Refresh.

Note: The parameter window must be closed before refreshing and opened again after refreshing.

There are five alternative formats in which parameters are shown: default, binary, hexadecimal, integer and float format. To change the format of a parameter, right-click and select either Use default format, Use binary format, Use hexadecimal format, Use integer format or Use float format.

You can change the widths of the columns by dragging the vertical lines between the column headers.
Double-click the value field box to see the bit names of certain binary parameters. For example, see the below parameter 10.1 DI status.

![Parameter window](image)

Figure 55. Bit names for a parameter

To reset a parameter, right-click it and select **Reset to default**.

Parameter values are read once when a group is opened. Independent parameters from different groups can be set to the Auto-update mode by right-clicking them and selecting **Add to auto-update**. The parameters that are updated automatically are seen with a yellow background as shown in the following figure.

**Note:** Signals are automatically updated cyclically
Parameters or signals can be sent to the monitor window by right-clicking them and selecting **Send to monitor**. Parameters can be copied to a custom parameter window by right-clicking them and selecting **Copy**. In addition, you can drag and drop parameters to a custom parameter window.
**Pointer parameters**

One special type of a parameter is a pointer parameter. The value of a pointer parameter is read from the parameter it points to. Depending on the pointer parameter, value or bit pointer, its target can be another parameter or one of its bits. Some pointer parameters can be assigned Active (false) or Inactive (true).

In most cases, common settings are offered as a selection list. In those cases where the selection list does not offer the correct pointer, pointing can be done by selecting Other... from a selection list.

![Figure 57. Constant value for a pointer parameter](image)

Select a parameter from the list for a value pointer and then its bit from 0 to 31 for a bit pointer.

You can also enter a value manually by selecting the Edit manually check box. The value must follow form P.#.#.#, where the first # is the parameter group number, the second # is the parameter number and the third # is the bit number without leading zeros (for example P.2.1.2).

Active (false) or Inactive (true) are the constant values that can be entered manually.
A bit pointer value can also be inverted by selecting the Invert value check box.

![Parameter window](image)

**Figure 58. Inverting a bit pointer value**

The inverted bit pointer value is shown with the minus sign at the end of the parameter.

![Inverted bit pointer value with the minus sign](image)

**Figure 59. Inverted bit pointer value with the minus sign**
### Setting fieldbus data in/out parameters

Process data transferred to and from the drive/PLC is set with parameter groups 52 and 53. With an ACS880 drive it is possible to select the data type for each selected parameter/signal in these group.

1. Double-click FBA data in/out parameter and select **Other**.

![Figure 60. Selecting the data type](image_url)
2. Select the format in which the value is handled: 16-bit, 32-bit or floating point format.

![Parameter window screenshot](image)

**Figure 61. Selecting the format**

In the parameter window, the selections are shown inside brackets: \[16\], \[32\] or \[F\].

<table>
<thead>
<tr>
<th>52. FBA data in</th>
<th>Value</th>
<th>Unit</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 FBAA.data in1</td>
<td>1.1[16]</td>
<td>NoUnit</td>
</tr>
<tr>
<td>2 FBAA.data in2</td>
<td>1.11[16]</td>
<td>NoUnit</td>
</tr>
<tr>
<td>3 FBAA.data in3</td>
<td>1.7[16]</td>
<td>NoUnit</td>
</tr>
<tr>
<td>4 FBAA.data in4</td>
<td>None</td>
<td>NoUnit</td>
</tr>
<tr>
<td>5 FBAA.data in5</td>
<td>1.4[16]</td>
<td>NoUnit</td>
</tr>
</tbody>
</table>

**Figure 62. Formats shown inside brackets in the parameter window**

**Note:** The floating point or 32-bit value reserves 2 slots in the configuration. Consequently, if you try to select a value for parameter 52.04 as in the figure above, you get a Parwrite failed error message. The scalings of parameters/signals are found in *ACS880 primary control program firmware manual* (AUA0000085967 [English]).

**Note:** You should always check the parameter mapping from the manual of the used fieldbus protocol. Example, FENA-01/-11/-21 Ethernet adapter module user's manual (3AUA0000093568 [English]) or FPBA-01 PROFIBUS DP adapter module user's manual (3AFE68573271 [English]).
Binary parameters

Binary parameters have a special meaning for each of their bits. These parameters are modified in a special Set binary parameter dialog. The value can be modified numerically in binary, hexadecimal or decimal format.

You can modify the values in the bit by double-clicking the value field for each bit. Some bits are greyed out and disable to edit.

Another way to modify a bit is to type the bit value directly to the New value [bin] / [hex] / [dec] field.

Signal values, which are in binary format, can be viewed in a similar dialog.

Figure 63. Binary parameter editor
## Search for groups and parameters

You can search the names of parameters and groups inside the parameter window. The search result is a list of all parameters matching the search text criteria. For example, all torque-related parameters can be found by entering search criteria “torque” in the Enter keyword field and clicking the Filter check box. To uncheck the Filter box, click it again.

![Parameter window](ZCU12_1.png)

### Figure 64. Search example

**Note:** The first search takes about 30…60 seconds, because Drive composer goes through the whole parameter structure. The next searches are fast. All searches are in memory of the PC as long as Drive composer is on.

<table>
<thead>
<tr>
<th>Index</th>
<th>Name</th>
<th>Value</th>
<th>Unit</th>
<th>Min</th>
<th>Max</th>
<th>Default</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Torque reference to TC</td>
<td>0.0</td>
<td>%</td>
<td>-1000.0</td>
<td>1600.0</td>
<td>0.0</td>
</tr>
<tr>
<td>2</td>
<td>Torque reference used</td>
<td>0.0</td>
<td>%</td>
<td>-1600.0</td>
<td>1600.0</td>
<td>0.0</td>
</tr>
<tr>
<td>3</td>
<td>Minimum torque ref</td>
<td>-300.0</td>
<td>%</td>
<td>-1000.0</td>
<td>0.0</td>
<td>-300.0</td>
</tr>
<tr>
<td>9</td>
<td>Maximum torque ref</td>
<td>300.0</td>
<td>%</td>
<td>0.0</td>
<td>1600.0</td>
<td>300.0</td>
</tr>
<tr>
<td>11</td>
<td>Torque ref1 source</td>
<td>Zero</td>
<td>NoUnit</td>
<td>Zero</td>
<td></td>
<td></td>
</tr>
<tr>
<td>12</td>
<td>Torque ref2 source</td>
<td>Zero</td>
<td>NoUnit</td>
<td>Zero</td>
<td></td>
<td></td>
</tr>
<tr>
<td>13</td>
<td>Torque ref1 function</td>
<td>Ref1</td>
<td>NoUnit</td>
<td>Ref1</td>
<td></td>
<td></td>
</tr>
<tr>
<td>14</td>
<td>Torque ref1/2 selection</td>
<td>Torque reference 1</td>
<td>NoUnit</td>
<td>Torque reference 1</td>
<td></td>
<td></td>
</tr>
<tr>
<td>16</td>
<td>Torque additive 1 source</td>
<td>Zero</td>
<td>NoUnit</td>
<td>Zero</td>
<td></td>
<td></td>
</tr>
<tr>
<td>17</td>
<td>Torque ref filter time</td>
<td>0.000</td>
<td>s</td>
<td>0.000</td>
<td>30.000</td>
<td>0.000</td>
</tr>
<tr>
<td>18</td>
<td>Torque ramp up time</td>
<td>0.000</td>
<td>s</td>
<td>0.000</td>
<td>50.000</td>
<td>0.000</td>
</tr>
<tr>
<td>19</td>
<td>Torque ramp down time</td>
<td>0.000</td>
<td>s</td>
<td>0.000</td>
<td>50.000</td>
<td>0.000</td>
</tr>
<tr>
<td>25</td>
<td>Torque additive 2 source</td>
<td>Zero</td>
<td>NoUnit</td>
<td>Zero</td>
<td></td>
<td></td>
</tr>
<tr>
<td>26</td>
<td>Force torque ref add 2 zero</td>
<td>Not selected</td>
<td>NoUnit</td>
<td>Not selected</td>
<td></td>
<td></td>
</tr>
<tr>
<td>41</td>
<td>Torque step</td>
<td>0.0</td>
<td>%</td>
<td>-300.0</td>
<td>300.0</td>
<td>0.0</td>
</tr>
</tbody>
</table>
Custom parameter window

In Drive composer it is possible to customize parameter windows. This means that parameters/signals can be dragged and dropped or copied from the main parameter window or from other custom parameter windows. You can rename custom parameter windows.

For example, you can collect all the typical parameters used in a quick start-up to one window. You can create separate windows for separate functions (for example, references, limits, ACS880 I/O). Custom parameter windows open automatically when a connection to a drive is made because they are saved with the workspace. Custom parameter windows can also be opened separately.

Parameter values can be changed in custom parameter windows. Custom parameter windows can be used both in tabbed and floating windows environments.

Separate custom parameter windows can be also saved to a file by selecting **Save parameters to file**. The changed values in the Offline value column are saved as well. Therefore the contents of a custom parameter window can be used for the parameterization of another drive. You can send the saved custom parameter windows to other users and they can open them with their Drive composer to see parameters that you want them to check or download to a drive.

**Note:** When a custom parameter window is saved, the actual drive values of the Value column are copied to the Offline value column. During loading the values in the Offline value column are shown in comparison with the current actual values. When you open the file containing the saved custom parameter window you can copy the values of the Offline value column to another drive by clicking the **Download to device** button.

Figure 65. Download to device button

In a network of drives, you can create a custom parameter window including parameters/signals selected from different drives. To have a view where all parameters are from one drive, click the **Change drive** button and select the drive.

To see the value of a parameter/signal used in another drive, right-click the parameter/signal and select **Change drive**.

Figure 66. Change drive button
Adding parameters to a custom parameter window

The following example shows how to:
• create a new custom parameter window
• add parameters to a custom parameter window
• modify the Offline value column in the custom parameter window
• copy/download parameters to a drive.

1. Click **File –> New –> Custom parameter set**.

![Figure 67. Custom parameter set](image)

2. Name the custom parameter window.

![Figure 68. Name of window](image)

3. Click **Add** button to add parameters/signals to the new custom parameter window or copy/paste from other parameter window.

![Figure 69. Add parameter button](image)
4. Select the minimum and maximum speed values from group 30.

![Choose parameters](image)

---

**Figure 70. Add minimum and maximum values**

5. Change the values in the Offline value column to be the same as the online values.

   **Note:** The values in the Offline value column do not have to be the same as the online values.

6. Save the custom parameter window by clicking the **Save parameters to file** icon.

![Test](image)

---

**Figure 71. Save parameter to file icon**

7. When connecting the next drive open the created custom parameter window by clicking **File -> Open -> Custom parameter file**.

   You can now see the online values of the new drive.
74  Parameter window

8. Copy the offline parameter values to a new drive by clicking **Download to device**.

![Parameter window with values](image)

*Figure 72. Download to device*
Working with offline files

Types of offline files

There are two types of offline files containing parameter information.

- **Parameter file** is an offline file containing all parameter values.
- **Support package** is an offline file package that contains a collection of drive information, including all parameter values. You can open a support package file using Drive composer pro. For further information on support package, see chapter Diagnostics on page 99.

Saving parameters to a parameter file

To save parameters to a file, proceed as follows:

1. Connect to a drive and open parameter window.
2. In the parameter window, click **Save parameters to file** icon.
3. Select a folder, enter a name for the dcparamsbak file and click **Save**.

Figure 73. Save parameters to file icon

Figure 74. Saving the dcparamsbak file
Opening a parameter file (entry)

To open a parameter file and view the parameter values offline, proceed as follows:

1. Connect to a drive.
2. Go to File -> Open -> Parameter file.
3. Parameter window displays.

Opening an offline file containing parameter values (pro)

To open a file and view the parameter values offline, proceed as follows:

1. Connect to a drive.
2. Go to File -> Open -> Parameter file / Open Support package.
3. New item appears under File drives.
4. Select Parameters to open parameter window.

![Figure 75. Opening parameters from Parameter file](image)

![Figure 76. Opening parameters from Support package](image)

Downloading parameter values to a drive

**Note:** The operation do not perform full restore. Only visible parameters and ID run results are copied to a drive when the download command is used. Also, drive type and software version are not checked when downloading parameter values from an offline file to a drive.

For further information on Restore function, see chapter *Other functions* on page 131.

To download offline parameter values to a drive, proceed as follows:

1. Open an offline parameter window.
2. If you have multiple drives connected online, click Change drive to select a drive you want to download the parameters.

![Figure 77. Changing drive](image)
3. Download the parameter values to a drive by clicking the **Download to device** icon.

![Figure 78. Download to device icon](image)

4. If you get a message indicating that the upload of parameter values is going on, click **OK**.

You will get a report of the operation at the end of the restore operation.

5. Check the parameters that are failed during the restore operation.

### Comparing drive data (pro)

**Note:** Both versions of Drive composer have **Not at default** function for listing user-changed parameters. The **Compare drive data** function compares parameter values.

With Drive composer pro you can compare parameters between
- two drives
- two parameter files
- drive and parameter file.

1. Go to **Tools –> Compare drive data (Alt+C)**.

![Figure 79. Comparing drive parameters](image)
2. In a PC tool network, select drives from **Drive A** and **Drive B** drop-down menus.

3. To open a parameter file for comparison, click **Open**.

4. To see the parameter list without differences, deactivate **Show differences** check box.

5. Click **Start compare**.
   
   **Note:** The operation may take a some time to compare two different parameter structures.

   The following figure shows an example of the result.

   ![Comparison Result](image)

   **Figure 80. Result of a comparison**

6. To export the result to a text (*.txt) file, click the **Export**.

   **Note:** Click the >> << buttons to copy parameter values from Drive A to Drive B.
Monitor window

Contents of this chapter
This chapter describes the monitor window and its use.

Monitor window
In Drive composer you can monitor the operation of connected drives. In the online mode, the monitor window shows signal values in graphical or numerical format. The monitor data can be saved to a file for later use.

With Drive composer entry you can monitor up to 8 signals.

With Drive composer pro you can monitor up to 26 signals. If Drive composer pro is used with an ACS880 drive, it is possible to monitor 1 signal per 1-ms time interval.

The monitor window is always a tabbed window, in other words, there is only one monitor window available.

User-made monitoring settings (selected signals, y-scalings for signals, pen colors, number of grids etc.) are saved by default. In other words, when you open the tool, there are always the latest settings available.
Resizing the monitor window

When you start Drive composer the monitor window is in the minimized position and you have to lift it in the following way before you can start monitoring.

- You can resize the monitor window by clicking the title bar with the primary mouse button and dragging it upwards.

- You can resize the monitor window with the Minimize, Maximize and Split monitor buttons included in the Monitor menu bar.

- You can lift the monitor window by clicking the arrow buttons in the title bar.
Adding parameters/signals for monitoring

There are two ways to add parameters/signals to the monitor window:

- Right-click a parameter/signal in the parameter window and select **Send to monitor**.
- Click the **Add signal** icon on the configurations and control area in the monitor window.

Select parameters from the Drive parameters list by double-clicking them or select a parameter and click Add button. You can add maximum of 26 parameters in Drive Composer pro and 8 parameters in Drive Composer entry.

**Note:** With Drive composer pro you can select signals/parameters from many different drives. Change the drive from the Drive list as shown in the following figure.
Note: In the PC tool network via Ethernet or with a panelbus, it is recommend that you select **Disable polling** to enable the best sampling result for monitoring. The status of the drive(s) cannot be read before you have unselected **Disable polling**.

Figure 84. Drive list

The selected signals appear in the legend area.
To change the scalings of the y-axis of selected parameters/signals, click the Min or Max column in the legend area.
Active signals can be changed from the pull-down menu on the left side of the graph area.
All the other signal scalings are performed on the right side of the legend area. The right side y-scalings can be hidden by removing the check mark from the Y-scale column check box.

Figure 85. Changing the pen color and style in the legend area

You can change the color and thickness of the pen only after you have minimized, that is hidden, the legend area with the **Arrow** button on the left (see the figure above).
To change the scalings of the y-axis for selected parameters/signals, click the Min or Max column in the legend area.
Monitor window components

The monitor window consists of the following parts:
- Configuration and control settings
- Graph area
- Y-axis
- X-axis
- Legend area
- Limit, color settings.
## Configuration and control settings

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Image]</td>
<td>Opens the saved monitored file to the graph area, which can be done only after monitoring has been stopped. File extension is *.dcemon or *.dcpmon. <strong>Note:</strong> If you have an online connection and want to start a new monitoring session after viewing opened monitored data, you can click the Monitor configuration icon.</td>
</tr>
<tr>
<td>![Image]</td>
<td>Saves the accumulated monitor data to a monitored data file. File extension is *.dcemon for the entry version and *.dcpmon for the pro version.</td>
</tr>
<tr>
<td>![Image]</td>
<td>Chart configuration can be used to set the colors for grids, number of grids, background color, color of alarm pen etc.</td>
</tr>
<tr>
<td>![Image]</td>
<td>Opens the Monitor settings window where you can modify the monitor settings and select the sample interval time for monitoring. You can also set the method for starting and/or stopping monitoring (by hand/time). You have to select the HD where the saved data is stored. <strong>Note:</strong> The monitored data is saved cyclically to the selected file. Created monitoring configuration can be saved and restored from Monitor settings window.</td>
</tr>
<tr>
<td>![Image]</td>
<td>Allows you to create an arithmetic signal for monitoring by using two signals used in monitoring. Available operations are ADD, SUB, MUL and DIV. <strong>Note:</strong> Remember to save settings in a workspace.</td>
</tr>
<tr>
<td>![Image]</td>
<td>Opens a dialog where you can add or remove one signal or several signals from the monitor configuration. <strong>Note:</strong> You can use the Add signal function only when monitoring has been stopped.</td>
</tr>
<tr>
<td>![Image]</td>
<td>Shows the signal values in text format. Only the values seen in graph area are included in the numeric signal value list.</td>
</tr>
<tr>
<td>![Image]</td>
<td>Copies the monitoring graph to a clipboard.</td>
</tr>
<tr>
<td>![Image]</td>
<td>Scales the y-axis automatically. <strong>Note:</strong> Zooming is not possible in the Autoscaling mode.</td>
</tr>
<tr>
<td>![Image]</td>
<td>Resets both x- and y-axis zooming to original 100%.</td>
</tr>
<tr>
<td>![Image]</td>
<td>You can export the monitored data in csv format to a PC. Exported data can analyzed with other tools. Use the Tab key for delimiting the columns. File extension is *.dcexp.</td>
</tr>
<tr>
<td>![Image]</td>
<td>Aligns signals.</td>
</tr>
<tr>
<td>![Image]</td>
<td>Selects or changes the drive.</td>
</tr>
<tr>
<td>![Image]</td>
<td>Zooms in the x- and/or y-axis up to 1000%.</td>
</tr>
</tbody>
</table>
## Monitor controls

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Play" /></td>
<td>Starts recording data in the selected drives and displaying it on the screen.</td>
</tr>
<tr>
<td><img src="image" alt="Pause" /></td>
<td>Pauses monitoring on the screen but monitoring continues on the background. When you click the Pause icon again, all values are seen and monitoring continues normally.</td>
</tr>
<tr>
<td><img src="image" alt="Stop" /></td>
<td>Stops recording data in the selected drives. The graph or numerical values remain on the screen. The graph can be saved for later purposes.</td>
</tr>
</tbody>
</table>
Active signal

The Active signal area consists of functions that can be done with the selected active signal. The signal can be changed from the pull-down menu.

Figure 86. Active signal area

The main functions are the following:

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
</table>
| ![Icon](image) | Allows you to see the measuring points of the active signal. See figure Measuring points for the active signal.  
**Note:** This functionality works only if you have zoomed in enough in the graph area, that is, if the length of the x-axis is short enough. |
| ![Icon](image) | Allows you to see the numeric values of the measuring points for the active signal. See figure Measuring points for the active signal.  
**Note:** This functionality works only if you have zoomed in enough in the graph area. |
| ![Icon](image) | Searches to the left. The following search conditions can be selected from the pull-down menu: Above, Below or Either. See figure Search functionality. |
| ![Icon](image) | Searches to the right. The following search conditions can be selected from the pull-down menu: Above, Below or Either. See figure Search functionality. |

Figure 87. Measuring points for the active signal
Zooming

To enlarge the graph and take a closer look at the details, follow these steps:

1. To set the starting corner for the enlargement, place the mouse cursor in the graph area and press down the primary mouse button.

2. Drag to the opposite desired corner, and release the button.
   The part of the graph that was inside the selection rectangle zooms out to fill the graph area.

3. To reset the zoom tool, click the **Reset zoom** icon.

You can also use the zooming tool by selecting independent values from x and y pull-down menus.

**Note:** Monitoring is paused during zooming. To continue monitoring, click the **Reset zoom** icon shown in the figure below.

Panning

The graph can be panned by dragging the graph with the right mouse button pressed down.
Legend area functions

The legend area shows selected signals. You can perform the following actions in the legend area:

- Change the color of the pen, thickness and style of the pen by minimizing the legend area and setting the values of each signal. See figure `Legend area functions`.
- Make signals visible or invisible by clicking the check box in the Visible column.
- Set a bit mask for monitoring. When you double-click the value in the Mask column, a new window opens allowing you to select bits for monitoring.
- Make Y-scalings visible or invisible by clicking the check box in the Y-scale column.
- Set values for y-axis scaling. You can modify the minimum and maximum values by clicking them and entering a new value. Press Enter to enforce the new value or press Esc to restore the value.

**Note:** If you do not see immediate changes in the graph area, check that autoscaling is not enabled.

- Set alarm limits for monitored signals. The color of a signal changes when the limit in the Alarm low or Alarm high column is reached. The color and style for the pen are selected from `Chart settings`.
- See the double cursor tool, y1 and y2 values and y2—y1 and x2—x1 differences.

![Figure 90. Legend area functions](image)

Graph area functions

The monitor window and data logger window have similar graph area facilities for displaying signal values. Their usage is described here. Before Drive composer starts monitoring online, the OnLine monitor text is seen in the graph area. When monitor files are viewed, the DataFile Viewer text is seen in the monitor window.

The graph area shows the selected signal values with different colors. The x-axis represents Time and can be set from 1 to 120s. You can change the values in online monitoring mode. Scalings of the y-axis are changed in the legend area.

For data logger files, an orange arrow-head on the x-axis indicates where triggering has occurred. Data can be combined from several files to one graph.
Double cursor tool

With the cursor tool, you can see the exact values of the signals at two positions in the graph area. You can move the position of cursors by clicking the primary mouse button down on the red cursor tool icon and moving it. While the mouse button is pressed down, you can move the cursor line to the left and right.

The time stamp of the cursor tool is shown in the header of the cursor tool. This is shown for the active signal. The time stamp changes if active signal is changed. The values for \( y_1 \) and \( y_2 \) are shown in the legend area. Signal value differences are shown in the column \( y_2-y_1 \). The time difference for \( x_2-x_1 \) is also shown in the figure below.

![Figure 91. Double cursor tool](image-url)
Monitor window
Workspace handling

Contents of this chapter
This chapter describes the workspace functionality.

Overview
Workspace consists of the user interface status, such as parameter windows and custom parameter windows.
The current workspace status can be saved to a file and restored later.

Note: You cannot save/restore the following status data:
• drive control status
• If a drive has been controlled locally with Drive composer when the workspace is saved, the workspace is saved without the change in the drive control status.
• content, status and zooming levels of a stopped, paused or running monitor.

Note: Do not edit a workspace or graph file. The workspace (.dxml) and monitored data (.dcmon) files can contain binary data. For example, if the default workspace file is corrupted, Drive composer does not open. If Drive composer does not open, delete your default (.dxml) file from the PC and open Drive composer again.
Creating a workspace and using it as a default workspace

1. Make a connection to a drive.
2. Resize the monitor window to half a screen.
3. Create a new custom parameter window by clicking File –> New.. –> Custom parameter set and name it “Own limit window”.

Figure 92. Custom parameter set

4. In the File menu, click Save workspace to save the workspace.

Figure 93. Save workspace command

5. Create another custom parameter window and name it “Own reference window”.
6. Select floating windows by clicking View –> Floating windows.
7. Enter keyword “Limit” in the Enter keyword field of the main parameter window.
8. Select parameters in the main parameter window and drag and drop or copy them to custom parameter window Limit.
9. Clear the search result and enter keyword “ref” in the Enter keyword field.
10. Select parameters in the main parameter window and drag and drop or copy them to custom parameter window Own reference window.
11. Close the main parameter window.
12. Click Event logger icon in the drive list on the left.
13. Click **File → Save workspace** and name it “OwnWorkspaceFor_ACS880”. See figure **Save workspace command**.

![Save workspace dialog box](image)

**Figure 94. Name for your own workspace**

14. Close the connection to the drive and make a new connection.
15. Click **File** –> **Open**. –> **Open workspace** and open the workplace that you have saved.

Figure 95. Open workspace command

The workspace is ready to use for commissioning and maintaining drives.

The workspace can also be saved as a default workspace which opens automatically when Drive composer is started.
Event logger

Contents of this chapter

This chapter describes the event logger view and its use.

Event logger view

The event logger view displays the contents of an event logger of a connected drive. The contents of an event logger can be faults (stopping the drive), alarms or events. See the figure below.

With some drives there can be more data of a fault in the monitor window.

Note: Fault logger data can also be seen from other faults than the latest active faults.
The event logger always relates to a single drive and resides in its window.

The Icon column shows the following alarm and fault icons:
- Red circle with a white cross (x) means that the drive has a fault.
- Yellow triangle with an exclamation mark means that the drive has an alarm.
- Grey circle or triangle means that the fault or alarm has disappeared from the drive.

The time stamp for faults, alarms and events comes from the drive.

Faults, alarms and events can be sorted by clicking the header of the Fault column.

### Figure 96. Event logger view

<table>
<thead>
<tr>
<th>Drive</th>
<th>Icon</th>
<th>Time</th>
<th>Fault</th>
<th>Description</th>
<th>AUX code</th>
</tr>
</thead>
<tbody>
<tr>
<td>ZCU12_1 (2)(1)</td>
<td></td>
<td>19.02.2013 21:34:40.432</td>
<td>64FF</td>
<td>Fault reset</td>
<td></td>
</tr>
<tr>
<td>ZCU12_1 (2)(1)</td>
<td></td>
<td>18.02.2013 19:52:38.526</td>
<td>64FF</td>
<td>Fault reset</td>
<td></td>
</tr>
<tr>
<td>ZCU12_1 (2)(1)</td>
<td></td>
<td>18.02.2013 19:48:01.948</td>
<td>6591</td>
<td>Backup/Restore Timeout</td>
<td></td>
</tr>
<tr>
<td>ZCU12_1 (2)(1)</td>
<td></td>
<td>08.02.2013 09:44:03.557</td>
<td>A6A6</td>
<td>Supply voltage unselected</td>
<td></td>
</tr>
<tr>
<td>ZCU12_1 (2)(1)</td>
<td></td>
<td>08.02.2013 09:41:34.976</td>
<td>A6A6</td>
<td>Supply voltage unselected</td>
<td></td>
</tr>
<tr>
<td>ZCU12_1 (2)(1)</td>
<td></td>
<td>08.02.2013 09:30:08.856</td>
<td>A6A6</td>
<td>Supply voltage unselected</td>
<td></td>
</tr>
<tr>
<td>ZCU12_1 (2)(1)</td>
<td></td>
<td>08.02.2013 09:27:53.846</td>
<td>A6A6</td>
<td>Supply voltage unselected</td>
<td></td>
</tr>
<tr>
<td>ZCU12_1 (2)(1)</td>
<td></td>
<td>08.02.2013 09:19:45.148</td>
<td>64B1</td>
<td>Internal SSW fault</td>
<td></td>
</tr>
<tr>
<td>ZCU12_1 (2)(1)</td>
<td></td>
<td>08.02.2013 09:14:58.631</td>
<td>6581</td>
<td>Parameter system</td>
<td>10D</td>
</tr>
<tr>
<td>ZCU12_1 (2)(1)</td>
<td></td>
<td>08.02.2013 09:14:58.536</td>
<td>64B1</td>
<td>Internal SSW fault</td>
<td>A0</td>
</tr>
<tr>
<td>ZCU12_1 (2)(1)</td>
<td></td>
<td>08.02.2013 09:14:59.532</td>
<td>64A1</td>
<td>Internal file load</td>
<td>C</td>
</tr>
</tbody>
</table>
Fault data logger

The Fault data icon in the Event logger view shows that the drive has fault data that can be seen with a monitor component. The icon is visible only if the drive sports the functionality.

Figure 97. Fault data icon

When you click the icon, the following message appears: “Please wait. Loading fault data appears”. When the message box disappears, the data has been loaded.

Figure 98. Fault data logger in the monitor window

Save the fault data.

Note: To continue the normal monitoring, click the Monitor configuration icon in the Monitor controls box.
Event logger
Diagnostics

Contents of this chapter

This chapter describes how to troubleshoot a drive with the Support package button of Drive composer and a data logger included in the drive.

Support package

Support package is an offline package file that contains, for example, full parameter backup, system information, and event logger contents. The main purpose is to collect troubleshooting data and send it to the support personnel for analysis.

Creating a support package

By clicking the Support package button, you can create and save a support package file.

Figure 99. Support package button
Opening a support package (pro)

You can open Support package file in Drive composer pro by selecting File -> Open -> Support package, a new File drive appears. There is similar menu available with online drives.

Figure 100. Available modules of Support package

For further information on each module, see section System info on page 101, chapters Parameter window on page 59 and Event logger on page 95.
Drive application programming license

The drive application programming license N8010 is required for downloading and executing the program code on the ACS880 drive. In DriveComposerPro, select **System info** tab. Check if the appropriate license is loaded to the drive. If the required license code is not available, contact ABB representative.

![System info command](image)

**Figure 101. System info command**

**System info**

The System info tab provides basic information about the drive and its options, for example, drive type code and firmware version.

![System info](image)

**Figure 102. System info**

You can also set the time for the drive and name the drive.
Data logger (pro)

ABB drives have data logger(s) that can record data from various signals of a drive even if the drive is not connected to a PC. A Datalogger is operated with the Datalogger view.

Figure 103. Data logger configuration

The data collecting can be stopped with a specific stop command or automatically when a triggering condition is true in the drive. After data collection stops you can read and study the data in Drive composer pro.
The data logger view resembles the monitor window. Normally the data logger view provides data from a single drive.

![Data logger view](image)

*Figure 104. Data logger view*
## Data logger settings

The data logger settings window contains the following functions:
- Data logger commands
- Data logger content configuration
- Data logger trigger configuration

### Data logger commands

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>![green_triangle]</td>
<td>Start button records data in the current logger of the drive until data logger is triggered or stopped.</td>
</tr>
<tr>
<td>![red_square]</td>
<td>Stop button ends recording immediately without any post trigger recording.</td>
</tr>
<tr>
<td>![exclamation_mark]</td>
<td>Trigger button triggers the associated logger in the drive. Trigger data logger is displayed in data logger status with trigger code 15.</td>
</tr>
<tr>
<td>![upload_icon]</td>
<td>Upload button moves data from the drive to PC and draws it to the monitor window. Data logger replaces any previous data in monitor window.</td>
</tr>
<tr>
<td>![apply_button]</td>
<td>Apply button applies monitored signal and data logger sampling settings.</td>
</tr>
</tbody>
</table>

### Data logger content configuration

With the data logger content configuration you can determine which data logger of a drive is used.

![Data logger content configuration](image)

*Figure 105. Data logger content configuration*

- **Logger** determines which logger settings are modified. A drive has user logger(s) and factory logger(s). Factory logger settings cannot be modified.
• **Sampling interval** determines in microseconds how often the logger reads samples of the signal values. The time level shows the available lengths of the internal cycle time of the drive. Sample interval is formed from multiplier (1-65535) and time level selection.

• **Post trigger count** specifies how many samples are stored after the triggering condition occurs. Data logger total space count depends on the drive type, selected signal types and total signal count.

• **Sampling time** shows the minimum sampling time with a selected number of signals and a selected sample interval.

• **Logger signals panel** shows a list of the signals selected to record. You can add/remove a signal by clicking the Add signal icon.

To add parameters to the logger, proceed as follows:

1. In the Datalogger screen, click + to add parameters.
2. Select a parameter in the **Drive parameters** list and double-click or click **Add**. The parameter is added to Selected parameters.

![Figure 106. Parameter window](image)

**Note:** The maximum number of signals that a logger can record at one time depends on the drive. Add button is disabled when maximum number of parameters are reached.

3. To remove the parameter from Selected parameters, select the desired parameter and click **Remove**.
4. Click **Apply changes** after making the changes.
Data logger trigger configuration

Data logger has four triggers that can be configured to stop the data logger. After data logger has triggered, data logger samples post trigger amount of new samples.

![Trigger configuration](image)

Figure 107. Data logger trigger configuration
**Adding a trigger**

1. To modify the conditions of a trigger, select the trigger from the **Trigger** drop-down menu.

   Trigger 1 is normally used for user logger 1, Trigger 2 for user logger 2 etc.

2. Choose the type for the triggering condition from the **Type** drop-down menu.

   Following are the alternatives (however, not all of them are available at all times):
   - **Bit mask** stops according to the bit mask of the selected signal.
   - **Disabled** can temporarily disable a trigger condition.
   - **Falling edge level** stops according to the selected signal, triggering level and hysteresis values.
   - **Fault** stops when the drive reports a fault.
   - **Event** stops when the drive reports an event.
   - **Rising edge level** stops according to the selected signal, triggering level and hysteresis values.
   - **Warning** stops when the drive reports a warning.

3. If you use Rising edge level or Falling edge level as the type for the triggering condition, see **Using the level triggers**.

4. Click **Apply**.

**Using the level triggers**

When condition Rising edge level is used, the function wakes up when the actual value of the triggering signal is below the triggering level - hysteresis. Similarly, when condition Falling edge level is used, the function wakes up when the actual value of the triggering signal is above the triggering level + hysteresis.

<table>
<thead>
<tr>
<th>Rising edge</th>
<th>Triggering signal is below the triggering level when the data logger is started: Triggering occurs when the signal goes above the triggering level.</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Triggering signal is above the triggering level when the data logger is started: Triggering occurs when the signal goes above the triggering level, but before that the signal must go below the triggering level - hysteresis.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Falling edge</th>
<th>Triggering signal is above the triggering level when the data logger is started: Triggering occurs when the signal goes below the triggering level.</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Triggering signal is below the triggering level when the data logger is started: Triggering occurs when the signal goes below the triggering level, but before that the signal must go above the triggering level + hysteresis.</td>
</tr>
</tbody>
</table>

**Using bit mask trigger**

Bit mask trigger reads signal value and masks out user selected bits with given mask. Masking is done by using a logical AND operation. Masked value is compared to user given bit values selection. When masked value and bit values match, data logger is triggered.
Uploading triggered or stopped data logger data

1. In the data logger view select a logger from the Logger drop-down menu. If the logger status is stopped or triggered, data can be uploaded.

2. Click **Upload** to upload data to the monitor window.
   
   **Note:** If you want to continue normal monitoring after using the data logger, click **Monitor configuration** icon and select a sampling interval for monitoring.

3. Click **Add signal** icon to add signals for monitoring.

![Continue monitoring after using the data logger](image)

![Uploaded data logger data](image)
Amplitude logger (pro)

ABB drives have an amplitude loggers that can record data from various signals of a drive. The results of an amplitude logger 1 (current) are displayed by the following curve. Each parameter represents an amplitude range and shows what portion of the samples fall within that range.

Note: Data loggers or amplitude loggers are not available for all ABB drives.

Figure 110. Amplitude logger
Macro (pro)

ABB drives have Macro functionality that can automatize a task or sequence of tasks. Macros are used for parameter value setting to multiple networked drives when custom window functionality is not sufficient. Macros may also be used for tasks which require logical or conditional parameterization of a drive.

- Right-click a drive and select Macro.

![Figure 111. Macro command](Image)

A Macro screen displays.

![Figure 112. Macro](Image)
Macro commands

- Macro language

Macro language is based on PAWN. For general programming guidelines, refer to PAWN manual.

Note: Some PAWN features are disabled for security reasons, such as file operations and other external IO functions.

Simple example

Macro tries to read parameter 1.1 value from each target in 100 network channels.

```plaintext
main()
{
    for(new i = 0; i < 100; i++)
    {
        //note the channels are indexed instead of nodes
        // this should be modified according network topology

        //change target
        Target(i+1,1)
        new targetName[100]
        //get target name
        TargetName (targetName)

        //read parameter 1.1 value
        new Float:val0101 = ParRead(1,1);
        //output to console
        printf "%s(%d,%d): %f\n", targetName, 1, 1, val0101 ;
    }
}
```

- Additional macro commands

**Target**

Changes the target of the macro commands after target command is issued.

<table>
<thead>
<tr>
<th>Syntax</th>
<th>Returns</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Target (Channel, node)</td>
<td>0 if success, 1 if failed</td>
<td>Target (1, 10)</td>
</tr>
</tbody>
</table>
### Target name

Command reads the current target name as string.

<table>
<thead>
<tr>
<th>Syntax</th>
<th>Returns</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>TargetName (string)</td>
<td>0 if success, 1 if failed</td>
<td>//reserve name string new name[100]</td>
</tr>
<tr>
<td></td>
<td></td>
<td>if(TargetName(name)==0) {</td>
</tr>
</tbody>
</table>
|                    |                        | printf "target name is %s
" name           |

### Parwrite

Command writes parameter value to current target.

<table>
<thead>
<tr>
<th>Syntax</th>
<th>Returns</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>ParWrite (group, index, value)</td>
<td>0 if success, 1 if failed</td>
<td>//write value 1 to group 12 index 16</td>
</tr>
<tr>
<td></td>
<td></td>
<td>ParWrite (12, 16, 1)</td>
</tr>
</tbody>
</table>

### Parread

Command reads the parameter value to current target.

<table>
<thead>
<tr>
<th>Syntax</th>
<th>Returns</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>ParRead (group, index)</td>
<td>Parameter value or 0 if failed</td>
<td>//Read value of the parameter in group 10 index 5</td>
</tr>
<tr>
<td></td>
<td></td>
<td>On error, the error message is shown in the log</td>
</tr>
<tr>
<td></td>
<td></td>
<td>new Float:val = ParRead(10,5);</td>
</tr>
<tr>
<td></td>
<td></td>
<td>printf &quot;value of (%d,%d): %f\n&quot;, 10, 5, val105;</td>
</tr>
</tbody>
</table>

### Wait

Command delays the macro execution for given time in milliseconds.

<table>
<thead>
<tr>
<th>Syntax</th>
<th>Returns</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Wait (milliseconds)</td>
<td>0 in all cases</td>
<td>//wait 0.1 seconds</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Wait(100)</td>
</tr>
</tbody>
</table>

### Endmacro

Command ends the macro execution.

<table>
<thead>
<tr>
<th>Syntax</th>
<th>Returns</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>EndMacro()</td>
<td>0 in all cases</td>
<td>//End execution</td>
</tr>
<tr>
<td></td>
<td></td>
<td>EndMacro()</td>
</tr>
</tbody>
</table>
**Gotomacro**
Command changes the macro execution. Currently running macro execution is terminated.

<table>
<thead>
<tr>
<th>Syntax</th>
<th>Returns</th>
<th>Example</th>
</tr>
</thead>
</table>
| GotoMacro(string) | 0 in all cases | //Change execution to macro jeejee
new macrofilename[100]
macrofilename = "jeejee.p"
GotoMacro(macrofilename) |

**Message box**
Command shows message box with ok button.

<table>
<thead>
<tr>
<th>Syntax</th>
<th>Returns</th>
<th>Example</th>
</tr>
</thead>
</table>
| MessageBox (string) | 0 in all cases | //show messagebox
new message[100]
message = "dingalongdangdong"
MessageBox (message) |
Diagnostics
Contents this chapter

This chapter describes the use of control diagrams helping to understand the behavior of a drive.

Control diagrams

Control diagrams provide a graphical presentation of, for example, the control chain of a drive, the speed and torque control chains and the logic of Start and Stop functions. With these diagrams it is possible to see parameter values related to certain functions. Diagrams also illustrate the position of switches according to parameter values, which helps to understand how the drive logic works. The values of parameters can be changed via control diagrams. A control diagram consists of two levels. The top level shows an overview of the diagrams and connections between them.

Note: Control Diagrams are drive-specific and they are not available for all drive types.

Note: When you connect a drive for the first time, it takes sometime to upload control diagrams from the drive. If Control Diagrams are not found in the drive, Drive composer asks to upload diagrams from the local source (PC).
Launch Control Diagrams by clicking a drive and selecting **Diagrams**.

**Figure 113. Selecting control diagrams from the drive tree**

The top level of a diagram consists of several diagrams. To open one part of a specific diagram, click the top of a box. The figures below show an example of a top level control diagram and a lower level control diagram.

**Figure 114. Top level of a control diagram**
Figure 115. Lower level of a control diagram

To navigate back to the top level of a Control Diagram, click the **Diagrams top** icon. To navigate through the reference chain, click the buttons circled in the figure above.

To zoom the control diagrams, use the zooming tool in the top left-hand corner of a Control Diagram.

Figure 116. Zooming tool
Control diagrams (pro)
FSO configuration (pro)

Contents of this chapter

This chapter contains the configuration procedure of FSO-11 and FSO-12 safety functions with Drive composer pro and provides an example of how to configure these optional FSO safety functions modules.

Configuring FSO-11 and FSO-12

The safety configuration of FSO-11 and FSO-12 safety functions module is available only in Drive composer pro, DCPT-01 (code: 3AUA0000108087).

Note:
- Only trained persons are allowed to configure the safety functions.
- Stop the motor before configuring the safety functions modules. You cannot download/upload the configuration file to/from safety functions module or change the password when the motor is running.
- You need a password to copy the configuration to the safety functions.

For detailed information about FSO-11 and FSO-12, see the respective safety functions module user’s manual:
- FSO-11 safety functions module user’s manual (3AUA0000097054 [English]).
- FSO-12 safety functions module user’s manual (3AXD50000015612 [English]).

Hardware connection

The hardware connection is common for both FSO-11 and FSO-12 safety functions module. For instructions on the hardware connections see FSO-11 safety functions module user’s manual (3AUA0000097054 [English])/ FSO-12 safety functions module user’s manual (3AXD50000015612 [English]).
The following configuration description assumes that all hardware-related connections are made properly and the ID run procedure of the drive is completed.

**Setting the FSO-11 safety functions with Drive composer pro**

1. Start the drive equipped with the FSO-11 option module using the drive control panel. See *Using the drive control panel for starting the drive* on page 57.

2. Right-click on drive and select **Safety settings**.

3. Click **Upload from FSO**.

   **Note:** The motor must be stopped.

   Fault FSO Fault 7A8B appears on the drive.

4. Type the password (8 numbers).
5. Double-click on the value field and change all necessary configuration settings to match your safety configuration.

![Safety settings tab](image)

Figure 120. FSO-11: Safety settings tab

6. Click the Download to FSO and validate button.
   The password is required again.
   The following Validate dialog box appears.

![Validate dialog box](image)

Figure 121. FSO-11 Validate dialog box

7. Click Yes.
   The following dialog box appears.

![Safety configuration ok message](image)

Figure 122. Safety configuration ok message

8. Click OK.

9. Test your safety configuration when the motor is running.
10. Check the values of parameter group 200.
   
   **Note:** If there are wrong values, right-click the parameter and select *Refresh the parameter*.

![Parameter group 200](image1)

**Figure 123. FSO-11: Parameter group 200**

11. After testing save your safety settings by clicking *Save safety file*.

![Save safety file button](image2)

**Figure 124. FSO-11: Save safety file button**

If you want to change the password of the FSO safety functions module, click *Change password* button.

**Note:** Stop the motor when you initiate to change the password.
Setting the FSO-12 safety functions with Drive composer pro

1. Start the drive equipped with the FSO-12 option module using the drive control panel. See Using the drive control panel for starting the drive on page 57.

2. Right-click on drive and select Safety settings 2.
   The safety configuration that is already available in the drive is displayed. If there is no safety configuration, the view is empty.

3. Click Upload from FSO.
   
   Note: The motor must be stopped.
   When you upload the safety settings from FSO module to PC tool, the FSO goes into Configuration state and indicates a fault. You can exit the Configuration state by rebooting FSO module or by downloading the safety settings to the FSO. Step 7 below.
   
   The Fault **FSO general fault: 7A8B** appears on the drive.

4. Type the password (8 numbers).

   Figure 125. FSO-12: Selecting Safety settings

   Figure 126. FSO-12: FSO general fault 7A8B

   Figure 127. Typing the password
5. Double-click on the value field and change all necessary configuration settings to match your safety configuration.

![Image of FSO configuration settings in Safety group 200](image1)

**Figure 128. FSO-12 configuration in Safety group 200**

Set the following safety function parameters:

- **General parameters**: Check that the motor parameters are correct.
- **I/O**: Check that I/O parameters are set according to the installation (wiring) plan. Remove diagnostic pulsing from any unused I/O. Check possible safety relays and cascade connections.
- **Safety functions**: Check all safety settings. You must at least check and set the STO and SSE related settings, regardless of whichever FSO safety functions you use. The FSO activates the STO and SSE functions in internal fault situations. The FSO uses the STO and SSE functions for making the system safe. All other functions are used only for monitoring the drive.

Note that only the group **Safety** is referred with group number and index numbers (see figure **FSO-12 configuration in Safety group 200**) and all other group names like **FSOGEN**, **STO** and so on have only index numbers (see figure **FSO-12 configuration with only group names**).

For examples of configuration settings and list of group names, see **FSO-12 safety functions module User’s manual (3AXD50000015612[English])**.

![Image of FSO-12 configuration with only group names](image2)

**Figure 129. FSO-12 configuration with only group names**
6. Click **Save safety file** to save the FSO configuration to your PC.

7. Click **Download to FSO and validate**. The password is required again. The following Validate dialog box appears.
   
   **Note:** You can boot FSO without downloading to FSO using **Boot FSO**.

![Validate dialog box](image)

**Figure 130. Validate dialog box**

8. Click **Yes**.

   The following dialog box appears.

![Safety configuration ok message](image)

**Figure 131. Safety configuration ok message**

9. Click **OK**.

10. Test your safety configuration when the motor is running.

11. Right-click on drive and select **Parameters** to check the values in parameter group 200.

   **Note:** If there are wrong values, right-click the parameter and select **Refresh the parameter**.

![Parameter group 200](image)

**Figure 132. FSO-12: Parameter group 200**
12. After testing save your safety settings, click **Save safety file**.

![Image of safety settings table]

**Figure 133. FSO-12: Save safety file button**

If you want to change the password of the FSO safety functions module, click **Change password** button.

**Note:** Stop the motor when you initiate to change the password.
Printing the safety functions configuration report (Online)

With FSO-12 installed, you can print the online safety functions configuration report.

**Note**: The print option is available only in Drive Composer version 1.7 and later.

1. From the **Safety settings 2** view, click **Configuration Report**.

2. Select a print template and click **Continue**.

3. Fill in the Drive and FSO version information. Click **Next**.

---

**Figure 134. Safety configuration report: Safety settings 2 -> Print configuration Report**

**Figure 135. Safety configuration report: Select print template**

**Figure 136. Safety configuration report: Drive and FSO information**
The next screen(s) contain different aspects of safety configuration such as configured safety functions, commissioning checklist, and so on. Fill in the required details and click Next.

Figure 137. Safety configuration report: List of configured safety functions

Figure 138. Safety configuration report: FSO commissioning check list
4. In the final screen fill in the required details and click **Print preview**.

![Safety configuration report: Print preview](image1.png)

*Figure 139. Safety configuration report: Print preview*

5. Select the required printer settings and click **Print**.

![Safety configuration report: Printer settings](image2.png)

*Figure 140. Safety configuration report: Printer settings*

The configuration and commissioning report is printed based on the selected printer settings.
Printing the safety functions configuration report (Offline)

To print a FSO safety functions configuration report in the Offline mode, you must have a saved safety file. See section Setting the FSO-12 safety functions with Drive composer pro (page 123).

Note: The print option is available only in Drive Composer version 1.7 and later.


Figure 141. Safety configuration report: Tools -> Safety Configuration Report

2. Select the saved file to print and click Continue.

Figure 142. Safety configuration report: Select print file

Continue from step 3 in section Printing the safety functions configuration report (Online), page 127.
Other functions

Contents of this chapter

This chapter describes how to create a backup file of a drive and restore a drive. In addition, there are instructions on how to use the Drive parameter conversion tool.

Creating a backup of a drive

1. Click Backup/restore.

![Backup/restore command](image)

Figure 143. Backup/restore command

2. Select a folder for the backup drive and give a name of your backup.

3. Click Backup to start the backup process.

   The backup process takes a few minutes.
Restoring a drive

1. Click Backup/restore. See figure Backup/restore command.

2. Click Restore to select the backup file to the drive with default settings.

All available components are restored from the backup file. All unavailable components are preserved in the drive.

3. To select a custom set of components to be restored to the drive, click Advanced restore.

The parameter values that are not written to the drive are listed in the restore report after the restore process. If there are grey items in the advanced list, the drive does not allow the item to restore.

Note: Advanced restore option is available only in Drive composer pro version.
Using the Drive parameter conversion tool (pro)

The parameter files of some ACS800/ACS600 ABB drive types commissioned and maintained with DriveWindow can be accessed with Drive composer via the Drive parameter conversion tool.

**Note:** Not all ACS800/ACS600 drives and software are supported.

1. Go to **Tools → Drive parameter conversion tool.**

![Drive Parameter Conversion Tool](image)

*Figure 144. Drive parameter conversion – Introduction*
2. Click **Next** and select the appropriate ACS800/ACS600 parameter file.

![Browse File](Image)

*Figure 145. Drive parameter conversion – Browsing the ACS800/600 file*

3. Select an empty ACx80 parameter file with default values.

![Browse File](Image)

*Figure 146. Drive parameter conversion – Browsing the ACSX80 parameter file*
4. Select name for the drive.

Figure 147. Drive parameter conversion – Save target

**Note**: Do not overwrite the empty file.

5. Click **Next**.

6. Answer **Yes**.

The Conversion report shows the parameters which are converted successfully and failed. Read the report carefully and fix the parameter values manually for which the conversion was not successful.

Figure 148. Drive parameter conversion – Results
Using the PSL2 data logger (pro)

With BCU-x2 control unit, you can upload the PSL2 data logger files from the drive flash memory to PC local hard drive. The files contain real time data from the converter modules that help in fault tracing and analysis.

**Note:** The files can be uploaded from drive to local computer only. You cannot read the contents or open the files. For any further assistance contact ABB customer support.

- **Uploading PSL2 data logger files**

  1. Go to **Tools** → **PSL2 data logger**.

  ![PSL2 Data logger](image)

  **Figure 149. PSL2 Data logger**

  2. Using the left or right arrow buttons, place the PSU data logger file(s) that you want to upload in the right side box.

  3. In the Upload directory field, click **` `** and select an upload folder in your PC local hard drive.

  4. Click **Upload**...

    The selected files are transfered to your local folder.
Adaptive programming

Adaptive programming is a feature to control the operation of a drive by parameters. Each parameter has a fixed set of choices or a setting range. The parameters make the programming easy, but the choices are limited. You cannot customize the operation further.

The Adaptive programming makes easy customizing possible without the need of a special programming tool or language. The program is built of function blocks.

Figure 150. Adaptive programming

For further information on Adaptive programming, refer Adaptive programming application guide in List of related manuals.
Other functions
Further information

Product and service inquiries
Address any inquiries about the product to your local ABB representative, quoting the type designation and serial number of the unit in question. A listing of ABB sales, support and service contacts can be found by navigating to www.abb.com/searchchannels.

Product training
For information on ABB product training, navigate to new.abb.com/service/training.

Providing feedback on ABB Drives manuals
Your comments on our manuals are welcome. Navigate to new.abb.com/drives/manuals-feedback-form.

Document library on the Internet
You can find manuals and other product documents in PDF format on the Internet. Go to www.abb.com/drives/documents.
Contact us

www.abb.com/drives
www.abb.com/drivespartners